<!DOCTYPE html>
<!--[if lt IE 7]>      <html class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if IE 7]>         <html class="no-js lt-ie9 lt-ie8"> <![endif]-->
<!--[if IE 8]>         <html class="no-js lt-ie9"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en"> <!--<![endif]-->
<head>
<meta charset="UTF-8">
<meta name="apple-itunes-app" content="app-id=">
<meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=no">
<meta http-equiv="X-UA-Compatible" content="IE=Edge"/>

<title>&#8216;There must be something wrong with him:&#8217; Stabbing victim, detectives hope you can help ID random street attack suspect | Q13 FOX News</title>

<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://q13fox.com/xmlrpc.php">

<script async type="text/javascript" id="bob_tag_loader">
	var page_url         = "https:\/\/q13fox.com\/2019\/12\/13\/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect",
		cats             = "News",
		bob_story_author = "David Rose",
		bob_kw           = "",
		bob_desc         = "WANTED IN SEATTLE \u2013 Detectives need your help solving a vicious assault on an innocent man who was stabbed multiple times in downtown Seattle. The photos above show the suspect detectives are asking for your help to identify as he boards a Metro bus following the attack. You can see [&hellip;]",
		cat_data         = "&cats=" + encodeURIComponent(cats) + "&bob_kw=" + encodeURIComponent(bob_kw) + "&bob_desc=" + encodeURIComponent(bob_desc)  + "&story_author=" +  encodeURIComponent(bob_story_author) + "&page_url=" +  encodeURIComponent(page_url),
        bob_cb           = '1';

		bob_cb = ( ( new Date() ).getTime() + "" + Math.floor( Math.random() * 1000000 ) ).substr( 0, 16 );

	( function() {
		var bob_tag = document.createElement('script'),
			bts;

		bob_tag.type  = 'text/javascript';
		bob_tag.async = true;
		bob_tag.id    = "bob_tag";
		bob_tag.src   = ( 'https:' === document.location.protocol ? 'https://' : 'http://' ) + 'bob.dmpxs.com/static/bob_001.js?bob_cb=' + bob_cb + cat_data;
		bts           = document.getElementsByTagName('script')[0];

		bts.parentNode.insertBefore(bob_tag, bts);
	} )();
</script>
<meta name="description" content="WANTED IN SEATTLE – Detectives need your help solving a vicious assault on an innocent man who was stabbed multiple times in downtown Seattle. The photos above show the suspect detectives are asking for your help to identify as he boards a Metro bus following the attack." />
<meta name="keywords" content="news," />
<meta name="google-site-verification" content="QJXsRQXzFUnPM80m9qF4-BSYmBR7l2JZHS9XVVQ4XZ4" />
<meta name="p:domain_verify" content="b6228bea1d7671a78a13a75050035f3a" />
	<script type="text/javascript">
	var dataLayer = window.dataLayer = window.dataLayer || [];
	dataLayer.push( {"fireGTM":true,"propID":"UA-34133884-3","event":"dlReady","paragraphCount":13,"wordCount":541,"authorName":"David Rose","imageCount":2,"siteName":"Q13 FOX News","publishDateString":"Fri Dec 13 2019","originalContent":false,"classifyText":[],"categories":"News"} );
	</script>
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer',"GTM-TR9GQP");</script>
	<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//confiant-integrations.global.ssl.fastly.net' />
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//r-login.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//tribkcpq.wordpress.com' />
<link rel='dns-prefetch' href='//cdn2.trb.tv' />
<link rel='dns-prefetch' href='//unpkg.com' />
<link rel='dns-prefetch' href='//tribkcpq.files.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Q13 FOX News &raquo; Feed" href="https://q13fox.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Q13 FOX News &raquo; Comments Feed" href="https://q13fox.com/comments/feed/" />
	<script>
		window._acmDebug = window._acmDebug || [];
	</script>
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
	<link rel="canonical" href="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s2.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1573557586h&ver=5.3.1"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0-1' href='https://s1.wp.com/_static/??-eJyNUe1ShDAMfCF7GZz7+OX4LG3JlZ6B1CZw+vYWPBSHkeFXs0k22WzhnoznTrFTaHuTqA+xE7jHOqAKeJljo/ihh4KfYEHRBlsUGGICYm9JB/M8kRyzimab9lMySuJO4oD7OLFUizq0pZrNN5r0LjP717/59L7qXliS0RGHEoaH2hluragZb/zrajLXPDXVpk/Eti4yq0MFFN00dFXdmq05ur7Dn+kzllaMNDYjWJH5E0U/ae3r4rzEouZKNmYYyeOZj3eLJeyjJVOc4L/gP+HNEQKxszQ2vLYv1elyPF9O1bm6fQFOvfN7?cssminify=yes' type='text/css' media='all' />
<script>
var tribuneBOBooyalaTags = {"keywords":"","description":"WANTED IN SEATTLE \u2013 Detectives need your help solving a vicious assault on an innocent man who was stabbed multiple times in downtown Seattle. The photos above show the suspect detectives are asking for your help to identify as he boards a Metro bus following the attack. You can see [\u2026]","pageURL":"https:\/\/q13fox.com\/2019\/12\/13\/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect"};
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyVj2EKwjAMhS9kLQN1+kM8S9ZlM7Nra5NuzNPbTRFEQYRA0uTre4kegyJnbKqRdZfjmjBOz7TueKUzYLwTdDLPg2fpkRla/DLtfUUWVWKMGXCSpRv/hXt3ITcQjj+xDiWAuaiITLcPdzlj3ksPFLREqpJDFWxqyfHrXflKCbSsgRmFdU282Hg/gYU/BMH0M9ZQO39fKsjHPlpZ59Qfi21Z7PblYVN2d49DhNg='></script>
<script src='https://confiant-integrations.global.ssl.fastly.net/dsOXTihmBU_70HHUwmNf7qg_azA/gpt_and_prebid/config.js?ver=1.0.0'></script>
<script>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</script>
<script type='text/javascript' src='https://s2.wp.com/wp-content/themes/vip/tribune-plugins/acm-config/js/prebid-1.0.js?m=1565704406h'></script>
<script src='https://r-login.wordpress.com/remote-login.php?m=1572447918h&#038;action=js&#038;host=q13fox.com&#038;id=41640066&#038;t=1576296657&#038;back=https%3A%2F%2Fq13fox.com%2F2019%2F12%2F13%2Fthere-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect%2F&#038;ver=1526988078' async defer onload='check_remote_login()'></script>
<script>
function check_remote_login() {
	if ( 'function' === typeof WPRemoteLogin ) {
		document.cookie = "wordpress_test_cookie=test; path=/";
		if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
			WPRemoteLogin();
		}
	}
}
</script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/themes/vip/localtv-2/js/plugins/throttle-debounce.js?m=1517525007h'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://tribkcpq.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel='shortlink' href='http://via.q13fox.com/RsG92' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fq13fox.com%2F2019%2F12%2F13%2Fthere-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fq13fox.com%2F2019%2F12%2F13%2Fthere-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="&#8216;There must be something wrong with him:&#8217; Stabbing victim, detectives hope you can help ID random street attack suspect" />
<meta property="og:url" content="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/" />
<meta property="og:description" content="WANTED IN SEATTLE –

Detectives need your help solving a vicious assault on an innocent man who was stabbed multiple times in downtown Seattle.

The photos above show the suspect detectives are asking for your help to identify as he boards a Metro bus following the attack. You can see he has facial hair and he was wearing prescription glasses. He&#039;s carrying a winter fur-lined trapper&#039;s type hat and his jeans have holes and cuts in the thighs." />
<meta property="article:published_time" content="2019-12-14T03:50:15+00:00" />
<meta property="article:modified_time" content="2019-12-14T03:50:16+00:00" />
<meta property="og:site_name" content="Q13 FOX News" />
<meta property="og:image" content="https://tribkcpq.files.wordpress.com/2019/12/stabbing.jpg?quality=85&amp;strip=all&amp;w=1200" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="675" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@q13fox" />
<meta name="twitter:site" content="@q13fox" />
<meta name="twitter:text:title" content="&#8216;There must be something wrong with him:&#8217; Stabbing victim, detectives hope you can help ID random street attack&nbsp;suspect" />
<meta name="twitter:image" content="https://tribkcpq.files.wordpress.com/2019/12/stabbing.jpg?quality=85&#038;strip=all&#038;w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="article:publisher" content="https://www.facebook.com/Q13FOX" />
<meta property="article:author" content="https://www.facebook.com/Q13FOX" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/5d3a4599cc1b5c4176496909ea375afa?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/5d3a4599cc1b5c4176496909ea375afa?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="https://secure.gravatar.com/blavatar/5d3a4599cc1b5c4176496909ea375afa?s=114" />
<link rel='openid.server' href='https://q13fox.com/?openidserver=1' />
<link rel='openid.delegate' href='https://q13fox.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://q13fox.com/osd.xml" title="Q13 FOX News" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<script type="text/javascript">
 window._taboola = window._taboola || [];
_taboola.push( {"video":"auto"} );
!function (e, f, u) {
    e.async = 1;
    e.src = u;
    f.parentNode.insertBefore(e, f);
}(document.createElement('script'), document.getElementsByTagName('script')[0],
	'https://cdn.taboola.com/libtrc/localtv-network/loader.js'
);
</script>
<script>
window._newsroom = window._newsroom || [];
!function (e, f, u) { e.async = 1; e.src = u; e.defer = 1; f.parentNode.insertBefore(e, f); }(document.createElement('script'),
document.getElementsByTagName('script')[0], '//c2.taboola.com/nr/tribunebroadcasting-q13fox/newsroom.js'  );
</script>
<meta name="tribune-video" content="true">	<meta name="word-count" content="541">
				<meta property="fb:pages" content="" />
			
<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>
<link rel="manifest" href="/manifest.json">
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async defer></script>
<script>
  var OneSignal = window.OneSignal || [];
  OneSignal.push(["init", {
    appId: "8114904d-adc8-41c4-89f2-ab1b4b763a50",
    autoRegister: true, /* Set to true to automatically prompt visitors */
    httpPermissionRequest: {
      enable: true
    },
    notifyButton: {
        enable: true /* Set to false to hide */
    }
  }]);
</script>
<script>
function get_aamCookie (c_name) {
	var i,x,y,ARRcookies=document.cookie.split(";");
	for (i=0;i<ARRcookies.length;i++) {
		x=ARRcookies[i].substr(0,ARRcookies[i].indexOf("="));
		y=ARRcookies[i].substr(ARRcookies[i].indexOf("=")+1);
		x=x.replace(/^\s+|\s+$/g,"");
		if (x==c_name) {
				return unescape(y);
			}
		}
	}
</script>
		<style>
			.wpcom-related-posts ul li {
				list-style-type: none;
				display: inline-block;
			}
		</style>
				<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="application-name" content="Q13 FOX News" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Seattle and Western Washington&#039;s source for breaking news, weather, and sports. Home of Washington’s Most Wanted and the Seattle Seahawks." /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://q13fox.com/feed/;icon-uri=https://secure.gravatar.com/blavatar/5d3a4599cc1b5c4176496909ea375afa?s=16" /><script>
googletag.cmd.push(function() {
 googletag.pubads().setTargeting("s1","landing");
 googletag.pubads().setTargeting("pid", "20191213there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect" );
 googletag.pubads().setTargeting("ContentID", "580656" );
 googletag.pubads().setTargeting("Site", "41640066" );
 googletag.pubads().setTargeting("test", "" );

 ACMTags["728x90-atf"] =
    googletag.defineSlot( "/7287/ltv.kcpq.news/landing", [[970,250],[970,66],[970,90],[728,90]], "acm-tag-728x90-atf")
    .addService(googletag.pubads())
    .setTargeting( "fold", "atf" )
    .setTargeting( "tagId", "728x90-atf" )
    .defineSizeMapping(responsiveMappings["Leaderboard"])
   ; ACMBatches[ "firstBatchTags" ].push( ACMTags["728x90-atf"] );
 ACMTags["728x90-btf"] =
    googletag.defineSlot( "/7287/ltv.kcpq.news/landing", [[970,250],[970,66],[728,90]], "acm-tag-728x90-btf")
    .addService(googletag.pubads())
    .setTargeting( "fold", "btf" )
    .setTargeting( "tagId", "728x90-btf" )
    .defineSizeMapping(responsiveMappings["Leaderboard"])
   ; ACMBatches[ "secondBatchTags" ].push( ACMTags["728x90-btf"] );
 ACMTags["300x250-atf"] =
    googletag.defineSlot( "/7287/ltv.kcpq.news/landing", [[300,250]], "acm-tag-300x250-atf")
    .addService(googletag.pubads())
    .setTargeting( "fold", "atf" )
    .setTargeting( "tagId", "300x250-atf" )
    .defineSizeMapping(responsiveMappings["Box"])
   ; ACMBatches[ "firstBatchTags" ].push( ACMTags["300x250-atf"] );
 ACMTags["300x250-btf0"] =
    googletag.defineSlot( "/7287/ltv.kcpq.news/landing", [[728,90],[300,250],[2,2]], "acm-tag-300x250-btf0")
    .addService(googletag.pubads())
    .setTargeting( "fold", "btf" )
    .setTargeting( "tagId", "300x250-btf0" )
    
   ; ACMBatches[ "secondBatchTags" ].push( ACMTags["300x250-btf0"] );
 ACMTags["300x250-btf"] =
    googletag.defineSlot( "/7287/ltv.kcpq.news/landing", [[300,250]], "acm-tag-300x250-btf")
    .addService(googletag.pubads())
    .setTargeting( "fold", "btf" )
    .setTargeting( "tagId", "300x250-btf" )
    .defineSizeMapping(responsiveMappings["Box"])
   ; ACMBatches[ "secondBatchTags" ].push( ACMTags["300x250-btf"] );
 ACMTags["300x250-btf1"] =
    googletag.defineSlot( "/7287/ltv.kcpq.news/landing", [[300,250]], "acm-tag-300x250-btf1")
    .addService(googletag.pubads())
    .setTargeting( "fold", "btf" )
    .setTargeting( "tagId", "300x250-btf1" )
    .defineSizeMapping(responsiveMappings["Box"])
   ; ACMBatches[ "secondBatchTags" ].push( ACMTags["300x250-btf1"] );
 ACMTags["300x250-btf2"] =
    googletag.defineSlot( "/7287/ltv.kcpq.news/landing", [[300,250]], "acm-tag-300x250-btf2")
    .addService(googletag.pubads())
    .setTargeting( "fold", "btf" )
    .setTargeting( "tagId", "300x250-btf2" )
    .defineSizeMapping(responsiveMappings["Box"])
   ; ACMBatches[ "secondBatchTags" ].push( ACMTags["300x250-btf2"] );
 ACMTags["300x250-btf3"] =
    googletag.defineSlot( "/7287/ltv.kcpq.news/landing", [[300,250]], "acm-tag-300x250-btf3")
    .addService(googletag.pubads())
    .setTargeting( "fold", "btf" )
    .setTargeting( "tagId", "300x250-btf3" )
    .defineSizeMapping(responsiveMappings["Box"])
   ; ACMBatches[ "secondBatchTags" ].push( ACMTags["300x250-btf3"] );
 ACMTags["300x250-mid"] =
    googletag.defineSlot( "/7287/ltv.kcpq.news/landing", [[300,250],[300,600]], "acm-tag-300x250-mid")
    .addService(googletag.pubads())
    .setTargeting( "fold", "mid" )
    .setTargeting( "tagId", "300x250-mid" )
    .defineSizeMapping(responsiveMappings["Dualbox"])
   ; ACMBatches[ "secondBatchTags" ].push( ACMTags["300x250-mid"] );
 ACMTags["120x60-atf"] =
    googletag.defineSlot( "/7287/ltv.kcpq.news/landing", [[120,60]], "acm-tag-120x60-atf")
    .addService(googletag.pubads())
    .setTargeting( "fold", "atf" )
    .setTargeting( "tagId", "120x60-atf" )
    .defineSizeMapping(responsiveMappings["Menu"])
   ; ACMBatches[ "firstBatchTags" ].push( ACMTags["120x60-atf"] );
 ACMTags["oop"] =
    googletag.defineSlot( "/7287/ltv.kcpq.news/landing", [[1,1]], "acm-tag-oop")
    .addService(googletag.pubads())
    .setTargeting( "fold", null )
    .setTargeting( "tagId", "oop" )
    
   ; ACMBatches[ "firstBatchTags" ].push( ACMTags["oop"] );
 
 googletag.pubads().setTargeting( 'video', 'yes' );

 googletag.pubads().setTargeting("s2","");
 var utm_params = {};
  window.location.search.replace(/[?&]+([^=&]+)=([^&]*)/gi, function(str,key,value) { utm_params[key.toLowerCase()] = value; }
 );
 for (var k in utm_params) {
  if(k.indexOf("utm") === 0)
   googletag.pubads().setTargeting(k,utm_params[k]);
 }


 googletag.pubads().enableAsyncRendering();
 googletag.pubads().enableSingleRequest();
 googletag.pubads().disableInitialLoad();
 googletag.pubads().collapseEmptyDivs();

 googletag.enableServices();

});
</script>

<link rel="amphtml" href="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/amp/"><script src="https://s.ntv.io/serve/load.js" async defer></script>
	</head>

<body class="post-template-default single single-post postid-580656 single-format-standard customizer-styles-applied KCPQ highlander-enabled highlander-light">

	<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-TR9GQP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

		<header class="navbar navbar-inverse navbar-fixed-top">
		<div id="search-form" class="collapse">
			<div class="container">
				
<form class="form-inline" role="search" method="get" action="https://q13fox.com/">
  <input type="search" placeholder="Search for..." value="" name="s">
  <button type="submit" class="btn btn-large btn-inverse"><span class="visible-phone">Go</span><span class="hidden-phone">Search</span></button>
</form>
				<button class="btn btn-close btn-large btn-link" data-toggle="collapse" data-target="#search-form"><i class="icon-remove"></i></button>
			</div>
		</div>
		<nav id="top-navigation" role="navigation">
			<div class="container">
				<div class="top-nav-left">
						<a href="https://q13fox.com/live-streaming/" id="btn-livestream" class="btn btn-primary"><i class="icon-play-circle icon-large"></i> Replay: <span>Q13 News at 5 </span></a>
<a href="https://q13fox.com/program-schedule" class="btn btn-link"><i class="icon-time icon-large"></i>
Q13 FOX TV Schedule <span class="text-small"></span></a>


															</div>
				<div class="top-nav-right">
					<button class="btn btn-link" data-toggle="collapse" data-target="#search-form"><i class="icon-search icon-large"></i><span class="hidden-phone"> Search</span></button>
					<a href="https://q13fox.com/aboutus/" class="btn btn-link"><i class="icon-envelope icon-large"></i><span class="hidden-phone"> Contact Us</span></a>
				</div>
			</div>
		</nav>
		<nav id="main-navigation" role="navigation">
			<div class="navbar-inner">
				<div class="container">
					<a class="brand" href="https://q13fox.com" title="Q13 FOX News" rel="home">Q13 FOX News</a>
					<button type="button" class="btn btn-navbar" data-toggle="collapse" data-target=".nav-collapse">
						<i class="icon-reorder icon-2x pull-left"></i> <span>Menu</span>
					</button>

						<div class="nav-collapse collapse"><ul id="menu-with-subcategories" class="nav"><li id="menu-item-115242" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-115242"><a href="https://q13fox.com/category/news/">News</a></li>
<li id="menu-item-530590" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-530590"><a href="https://q13fox.com/videos/">Videos</a></li>
<li id="menu-item-435814" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-435814"><a href="https://q13fox.com/links-you-saw-on-tv/">Links</a></li>
<li id="menu-item-521836" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-521836"><a href="https://q13fox.com/category/all-local/">All Local</a></li>
<li id="menu-item-115250" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-115250"><a href="https://q13fox.com/category/this-morning/">This Morning</a></li>
<li id="menu-item-115252" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-115252"><a href="https://q13fox.com/category/sports/">Sports</a></li>
<li id="menu-item-115587" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-115587"><a href="https://q13fox.com/category/washingtons-most-wanted/">WMW</a></li>
<li id="menu-item-436105" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-436105"><a href="https://q13fox.com/q13-fox-apps/">Apps</a></li>
<li id="menu-item-519438" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-519438"><a href="https://q13fox.com/aboutus/">About</a></li>
<li id="menu-item-115256" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-115256"><a href="https://q13fox.com/traffic/">Traffic</a></li>
</ul></div>
						<ul id="nav-weather" class="nav">
							<li class="dropdown ">
		<a href="https://q13fox.com/weather/">
		<span class="hidden-phone">Weather </span>
		<i class="wi wi-night-partly-cloudy "></i>
		<strong class="temp">47&deg;</strong>
	</a>
		<ul class="dropdown-menu pull-right text-center" role="menu">
			<div class="row-fluid">
				<div class="currently span4">
					<i class="wi wi-night-partly-cloudy "></i>
				</div>
				<div class="temp span4">
					<strong>47&deg;</strong>
				</div>
				<div class="hi-lo span4">
					<div>Low <strong>42&deg;</strong></div>
					<div>High <strong>49&deg;</strong></div>
				</div>
			</div>
			<hr>
			<div class="row-fluid">
							<div class="span4">
				<div>Sat</div>
				<i class="wi wi-day-showers wi-4x"></i>
				<div>
					39&deg; <i class="icon-caret-right"></i> 46&deg;
					</div>
			</div>
						<div class="span4">
				<div>Sun</div>
				<i class="wi wi-day-sunny-overcast wi-4x"></i>
				<div>
					34&deg; <i class="icon-caret-right"></i> 44&deg;
					</div>
			</div>
						<div class="span4">
				<div>Mon</div>
				<i class="wi wi-day-sunny-overcast wi-4x"></i>
				<div>
					36&deg; <i class="icon-caret-right"></i> 45&deg;
					</div>
			</div>
						</div>
			<a href="https://q13fox.com/weather/" class="btn btn-block btn-inverse">See complete forecast</a>
					</ul>


							</li>
						</ul>
					<div class="ad">
									<div id='acm-tag-120x60-atf' class='prebid ad-wrapper' style='width:120px; min-height: 60px;'><script>
googletag.cmd.push(function() {
    googletag.display('acm-tag-120x60-atf');
   });</script></div>								</div>
				</div>
			</div>
		</nav>
	</header>
				<div id="site-wide-alerts" class="full-width hide">
												<div>
						<a href="https://q13fox.com/tag/season-of-giving/" class="site-wide-alert alert-green">
							<i class="icon-star icon-large"></i> SEASON OF GIVING: DONATE TO THE LES SCHWAB TOY DRIVE AND THE Q13 FOX SOCK&nbsp;DRIVE						</a>
					</div>
										</div>
	

	
		<div class="ad ad-top ad-long full-width ">
			<div id='acm-tag-728x90-atf' class='prebid ad-wrapper' style='width:px; min-height: 50px;'><script>
googletag.cmd.push(function() {
    googletag.display('acm-tag-728x90-atf');
   });</script></div>		</div>
	
	
<div id="content">
    <div class="container">
      <header class="entry-header">
        <h1 class="entry-title">&#8216;There must be something wrong with him:&#8217; Stabbing victim, detectives hope you can help ID random street attack&nbsp;suspect</h1>
        <div class="entry-meta clearfix">
          <span class="posted-time">Posted 7:50 PM, December 13, 2019, by <a href="https://q13fox.com/author/tribsteveroberts/" title="Posts by David Rose" class="author url fn" rel="author">David Rose</a></span>        </div>
        <div class="entry-share">
          <div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-580656" class="share-facebook sd-button share-icon" href="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-580656" class="share-twitter sd-button share-icon" href="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-580656" class="share-linkedin sd-button share-icon" href="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon" href="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-580656" class="share-pinterest sd-button share-icon" href="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-sms"><a rel="nofollow" data-shared="" class="share-sms sd-button share-icon" href="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/?share=sms" title="Click to share on SMS"><span>SMS</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon" href="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon" href="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div>        </div>
      </header>
      <div class="row">

        <div class="span8 span12-tablet border-right">
                  <img class="print-logo visible-print" src="https://s2.wp.com/wp-content/themes/vip/localtv-2/img/kcpq/logo-gray.png" />
        	                        <article id="post-580656" class="post-580656 post type-post status-publish format-standard has-post-thumbnail hentry category-news">
	<div class="entry-content">

		
				<p><strong><a href="https://tribkcpq.files.wordpress.com/2019/12/stabbing.jpg?quality=85&amp;strip=all&strip=all"><img class="aligncenter size-full wp-image-580657" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt width="770" height="433" data-lazy-src="https://tribkcpq.files.wordpress.com/2019/12/stabbing.jpg?quality=85&#038;strip=all&#038;w=770&#038;h=433"><noscript><img class="aligncenter size-full wp-image-580657" src="https://tribkcpq.files.wordpress.com/2019/12/stabbing.jpg?quality=85&#038;strip=all&#038;w=770&#038;h=433" alt="" width="770" height="433" srcset="https://tribkcpq.files.wordpress.com/2019/12/stabbing.jpg?quality=85&amp;strip=all&amp;w=770&amp;h=433 770w, https://tribkcpq.files.wordpress.com/2019/12/stabbing.jpg?quality=85&amp;strip=all&amp;w=1540&amp;h=866 1540w, https://tribkcpq.files.wordpress.com/2019/12/stabbing.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=84 150w, https://tribkcpq.files.wordpress.com/2019/12/stabbing.jpg?quality=85&amp;strip=all&amp;w=300&amp;h=169 300w, https://tribkcpq.files.wordpress.com/2019/12/stabbing.jpg?quality=85&amp;strip=all&amp;w=1024&amp;h=576 1024w" sizes="(max-width: 770px) 100vw, 770px" /></noscript></a>WANTED IN SEATTLE –<br />
</strong>Detectives need your help solving a vicious assault on an innocent man who was stabbed multiple times in downtown Seattle.</p>
<p>The photos above show the suspect detectives are asking for your help to identify as he boards a Metro bus following the attack. You can see he has facial hair and he was wearing prescription glasses. He&#8217;s carrying a winter fur-lined trapper&#8217;s type hat and his jeans have holes and cuts in the thighs.</p>
<p>The young man police say he attacked tells me he had never seen the suspect before, but he&#8217;s hoping somebody knows his name.</p>
<p>Dax Nicholas is still months away from being able to fully use his right hand. &#8220;Cut two tendons along this outside and this side.&#8221;</p>
<p>Surveillance video shows the random attack on 4th Ave. under the Yesler St. overpass on October 25th.</p>
<p>Nicholas was walking home from work when he was stabbed five times. &#8220;It bothers me that it was so senseless. It could have been anybody,” said Nicholas.</p>
<p>Video shows the suspect approaching Nicholas and then lunging at him. “I pull my headphones out and he&#8217;s like, ‘You don&#8217;t want to do this. I&#8217;ve got a knife’ and then he shoves me again. I&#8217;m thinking, ‘He&#8217;s not letting me go. Is he robbing me? What&#8217;s going on?’ So, I hit him in the face.&#8221; As the two fight, the suspect pulled out a knife with his left hand and stabbed Nicholas in the wrist, shoulders and face. “I ran away, up the road to the fire station and I called the cops.&#8221;</p>
<div class="sticky-panel p402_hide">			<div class="ooyala-container" style="max-width:770px;"> 			<div class="ooyala-sizer" style="width:auto;padding-top:56.233766233766%;position:relative"> 						<link rel="stylesheet" href="//player.ooyala.com/static/v4/production/skin-plugin/html5-skin.min.css" />  						<img src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt="Data pix." data-lazy-src="https://bob.dmpxs.com/bob_003.gif?d_code=0_0&#038;vid_asset_url=NmYmt3aTE6FkeEqL0pOxmMT6du_ct7VX&#038;vid_pageurl=https%3A%2F%2Fq13fox.com%2F2019%2F12%2F13%2Fthere-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect%2F"><noscript><img src="https://bob.dmpxs.com/bob_003.gif?d_code=0_0&#038;vid_asset_url=NmYmt3aTE6FkeEqL0pOxmMT6du_ct7VX&#038;vid_pageurl=https%3A%2F%2Fq13fox.com%2F2019%2F12%2F13%2Fthere-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect%2F" alt="Data pix." /></noscript> 							<div id="ooyalaplayer-1" class="ooyala-player ooyala-video-wrapper" style="position:absolute;top:0;right:0;bottom:0;left:0" ></div> 				<script> 					window.addEventListener( "load", loadOOready, false ); 					function loadOOready() { 						var ooyalaplayers = ooyalaplayers || [];  						OO.ready( function() { 							var op         = typeof window.ooyalaParameters === 'function' ? window.ooyalaParameters : function(params) { return params; }, 								JSONparams = ["ooyalaplayer-1","NmYmt3aTE6FkeEqL0pOxmMT6du_ct7VX",{"pcode":"VqYjUyOkWkUw5ULayoUpHorxtcBB","playerBrandingId":"c8cff4cec9d94ae0896f6443af7ee837","autoplay":false,"loop":false,"skin":{"config":"\/\/player.ooyala.com\/static\/v4\/production\/skin-plugin\/skin.json","inline":{"icons":{"discovery":{"fontFamilyName":"ooyala-slick-type","fontString":"N","fontStyleClass":"oo-icon oo-icon-discovery-binoculars"}},"startScreen":{"playButtonPosition":"center","showDescription":false},"pauseScreen":{"pauseIconPosition":"bottomLeft","showPauseIcon":true,"showDescription":false},"discoveryScreen":{"panelTitle":{"titleFont":{"fontSize":22,"fontFamily":"\"Open Sans Condensed\", \"Helvetica Neue\", Helvetica, Arial, sans-serif","color":"white"}},"contentTitle":{"show":true,"font":{"fontSize":18,"fontFamily":"\"Open Sans Condensed\", \"Helvetica Neue\", Helvetica, Arial, sans-serif","color":"white"}},"contentDuration":{"show":true,"font":{"fontSize":12,"fontFamily":"\"Open Sans Condensed\", \"Helvetica Neue\", Helvetica, Arial, sans-serif","color":"white"}},"showCountDownTimerOnEndScreen":true,"countDownTime":"5"},"upNext":{"showUpNext":true,"timeToShow":"5"},"controlBar":{"logo":{"imageResource":{"url":"https:\/\/s2.wp.com\/wp-content\/themes\/vip\/localtv-2\/img\/kcpq\/logo.png"},"clickUrl":"https:\/\/q13fox.com\/","target":"_blank","width":72,"height":24}},"closedCaptionOptions":{"enabled":false},"adScreen":{"showAdMarquee":true,"showAdCountDown":true,"showControlBar":true},"shareScreen":{"embed":{"source":"<iframe width='640' height='480' frameborder='0' allowfullscreen src='\/\/cdn2.trb.tv\/iframe.html?ec=<ASSET_ID>&pbid=<PLAYER_ID>&pcode=<PUBLISHER_ID>'><\/iframe>"}}}},"ComScoreOoyalaPlugin":{"labelmapping":"c3=\"KCPQ\", c4=\"*null\", c6=\"*null\", ns_st_st=\"KCPQ\", ns_st_pu=\"KCPQ\", ns_st_pr=\"*null\",  ns_st_ep=\"*null\", ns_st_sn=\"*null\", ns_st_en=\"*null\", ns_st_ge=\"*null\", ns_st_ti=\"*null\", ns_st_ia=\"0\", ns_st_ce=\"*null\", ns_st_ddt=\"*null\", ns_st_tdt=\"*null\"","publisherId":"18314522"},"Nielsen":{"sfcode":"dcr","apn":"Ooyala V4","apid":"PFCBCF056-14F7-4319-8622-A0C6BD243E5B","isfullepisode":"N","title":"&#8216;There must be something wrong with him:&#8217; Stabbing victim, detectives hope you can help ID random street attack&nbsp;suspect","program":"News","hasAds":"1","airdate":"20191213 19:50:15"},"google-ima-ads-manager":{"showAdControls":true,"useGoogleCountdown":true,"additionalAdTagParameters":{"referrer_url":"https:\/\/q13fox.com\/2019\/12\/13\/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect\/","cust_params":"d_code=0_0"}},"iosPlayMode":"inline","encodingPriority":["hls","hls_drm","dash","dash_drm","mp4","hds"]}];  							if ( typeof window.tribuneBobOoyala !== 'undefined' ) { 								JSONparams[2].onCreate = window.tribuneBobOoyala.onCreate; 							}  							ooyalaplayers.push( OO.Player.create.apply( OO.Player, op( JSONparams ) ) ); 						} ); 					} 				</script> 				<noscript><div>Please enable Javascript to watch this video</div></noscript> 						</div> 			</div> 			</div>
<p>Detectives say the suspect boarded a Metro bus, but got off when he couldn't find his money. "He then waits for the next Metro bus which he gets on, pays, takes a seat on the bus and travels all the way to what we think is Bellevue, where he gets off,” said Ret. Det. Myrle Carner with Crime Stoppers of Puget Sound. During that ride home, he switched buses. Video shows him bend over to pick up a piece of paper he'd dropped, you can see more of his balding head and hear him as he talks to another rider. "Somebody knows who this guy is and that's the information we need,” said Ret. Det. Carner.</p>
<p>The attack happened just a block south of the King County Courthouse -- an area plagued recently by violence. "If you see someone coming towards you and you feel uncomfortable, even if you have to cross the street, or turn around and go back. Do that,” said Ret. Det. Carner.</p>
<p>Nicholas said he had never been concerned about walking through the area before, but no longer walks that route home from work.</p>
<p>“This dude specifically, there must be something wrong with him,” said Nicholas. And, he believes he won't be the last victim if the suspect who ambushed him isn't caught. "He deserves time for this.”</p>
<p>Seattle Police say the suspect is in his 30's, 5’11” to 6’1”, with a medium build.</p>
<p>If you know his name, Crime Stoppers of Puget Sound will pay you a cash reward of up to $1,000. You will remain anonymous. Call 1-800-222-TIPS(8477), or use the P3 Tips App that you can download to your cell phone for free.</p>
<p><a href="https://tribkcpq.files.wordpress.com/2019/12/stabbing2.jpg?quality=85&amp;strip=all&strip=all"><img class="aligncenter size-full wp-image-580659" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt data-lazy-src="https://tribkcpq.files.wordpress.com/2019/12/stabbing2.jpg?quality=85&#038;strip=all&#038;w=770"><noscript><img class="aligncenter size-full wp-image-580659" src="https://tribkcpq.files.wordpress.com/2019/12/stabbing2.jpg?quality=85&#038;strip=all&#038;w=770" alt="" srcset="https://tribkcpq.files.wordpress.com/2019/12/stabbing2.jpg?quality=85&amp;strip=all 380w, https://tribkcpq.files.wordpress.com/2019/12/stabbing2.jpg?quality=85&amp;strip=all&amp;w=150 150w, https://tribkcpq.files.wordpress.com/2019/12/stabbing2.jpg?quality=85&amp;strip=all&amp;w=300 300w" sizes="(max-width: 380px) 100vw, 380px"   /></noscript></a></p>

		




	</div>

	<footer class="entry-meta clearfix">

			<hr>
	<div class="row-fluid">
		<div class="span8">

			<p><strong>Filed in:</strong> <a href="https://q13fox.com/category/news/" rel="category tag">News</a> </p>		</div>
		<div class="span4">
				<a href="#" class="pull-right" data-href="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/" data-target="#report-a-typo-modal" role="button" data-toggle="modal"><i class="icon-warning-sign"></i> Suggest a correction</a>


		<div id="report-a-typo-modal" class="modal">
		<div class="modal-content">
		  <div class="modal-header">
		    <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
		    <h3>Suggest A Correction</h3>
		  </div>
		  <div class="modal-body">
		  		<form action="https://tribkcpq.wordpress.com/wp-admin/admin-ajax.php" method="post" id="ugc-media-form-0" class="validate report-a-typo-form fu-upload-form" enctype="multipart/form-data">
	 <div class="ugc-inner-wrapper">
		 <h2></h2>
<input type="hidden" value="correction" name="post_type"  id='ugc-input-post_type' name='post_type' value='correction' /><input type="hidden" value="580656" name="post_ID"  id='ugc-input-post_id' name='post_ID' value='580656' />
		  		<div  class='ugc-input-wrapper'><label  for='report-a-typo-name'>Your name</label><input type="text" value="" name="name"  id='report-a-typo-name' name='name' class='required' required='true' /></div>
		  		<div  class='ugc-input-wrapper'><label  for='report-a-typo-email'>Your email</label><input type="text" value="" name="email"  id='report-a-typo-email' name='email' class='required' required='true' /></div>
		  		<div  class='ugc-input-wrapper'><label  for='report-a-typo-correction'>Report a typo or grammatical error</label><textarea  name='correction' id='report-a-typo-correction' class='required' required='true'></textarea></div>
		  		<input type="hidden" value=" Correction: &#8216;There must be something wrong with him:&#8217; Stabbing victim, detectives hope you can help ID random street attack&nbsp;suspect" name="post_title"  id='ugc-input-post_title' name='post_title' value=' Correction: &#8216;There must be something wrong with him:&#8217; Stabbing victim, detectives hope you can help ID random street attack&nbsp;suspect' class='required' />
		  		<input type="hidden" value="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/" name="story_url"  id='ugc-input-story_url' name='story_url' value='https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/' />
		  		<input type="hidden" value="report-a-typo" name="mode"  id='ugc-input-mode' name='mode' value='report-a-typo' />
		  		<input type="hidden" value="upload_ugc" name="action"  id='ugc-input-action' name='action' value='upload_ugc' /><input type="hidden" value="post" name="form_layout"  id='ugc-input-form_layout' name='form_layout' value='post' />		<input type="hidden" id="fu_nonce" name="fu_nonce" value="4f2d772c79" /><input type="hidden" name="_wp_http_referer" value="/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/" />		<input type="hidden" name="ff" value="59fbb689b36b842851bc216d5bb302bb" />
		<input type="hidden" name="form_post_id" value="580656" />
		<div class="clear"></div>
	 </div>
	 </form>

		  			  </div>
			<div class="modal-footer">
						<button type="button" class="btn pull-left" data-dismiss="modal" aria-hidden="true">Cancel</button>
						<input type="submit" value="Submit" name="" id="report-a-typo-submit" class="btn btn-large btn-primary pull-right">
			</div>
		</div>
		</div>

				</div>
	</div>
		<div class="entry-share">
		  <div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-580656" class="share-facebook sd-button share-icon" href="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-580656" class="share-twitter sd-button share-icon" href="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-580656" class="share-linkedin sd-button share-icon" href="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon" href="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-580656" class="share-pinterest sd-button share-icon" href="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-sms"><a rel="nofollow" data-shared="" class="share-sms sd-button share-icon" href="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/?share=sms" title="Click to share on SMS"><span>SMS</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon" href="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon" href="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div>		</div>
			</footer>
</article>
	<div id='taboola-below-article-thumbs-hybrid-mix'></div>
	<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push({"mode":"thumbs-3r","container":"taboola-below-article-thumbs-hybrid-mix","placement":"below-article-thumbs-hybrid","target_type":"mix"});
	</script>
	<div id='taboola-below-article-text-links'></div>
	<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push({"mode":"hybrid-text-links-2c","container":"taboola-below-article-text-links","placement":"below-article-text-links","target_type":"mix"});
	</script>
<div id="2x2-waypoint"></div><div class="after-post-ad">
	<div id='acm-tag-300x250-btf0' class='prebid ad-wrapper' style='width:350px; min-height: 250px;'><script>
googletag.cmd.push(function() {
    googletag.display('acm-tag-300x250-btf0');
   });</script></div></div>

	<div id="comments" class="comments-area">

	
	
	
	
</div>
							 </div>
         <div id="sidebar" class="span4 span12-tablet">
									<div class="row-fluid">
							<div class="span12 span6-tablet">
								<div class="ad border-bottom">
								<div id='acm-tag-300x250-atf' class='prebid ad-wrapper' style='width:300px; min-height: 250px;'><script>
googletag.cmd.push(function() {
    googletag.display('acm-tag-300x250-atf');
   });</script></div>								</div>

								
								
																<div class="ad">
									<div class="nativo border-bottom" id="nativo"></div>
								</div>
												<div class="border-bottom">


			<a href="https://q13fox.com/2019/04/04/orca-pod-cast-episode-1-the-last-generation-of-southern-resident-orcas/"
			class="station-promo"
			style="background-image:url( https://tribkcpq.files.wordpress.com/2019/04/podcast-2-e1554420231772.jpeg?quality=85&#038;strip=all&#038;w=770&#038;h=432&#038;crop=1 )">
	<span class="overlay">
  	<h3>Q13 News Orca&nbsp;Pod-Cast</h3>
	<p><p>Listen to episode 1 of our new podcast on the critically endangered southern resident orcas and the efforts to save them </p>
</p>
	<i class="icon-chevron-right"></i>
	</span>
	</a>
	

</div>
							</div>
						</div>

						<div class="row-fluid">

				<div class="ad border-bottom span12 span6-tablet">
						<div id='acm-tag-300x250-mid' class='prebid ad-wrapper' style='width:300px; min-height: 250px;'><script>
googletag.cmd.push(function() {
    googletag.display('acm-tag-300x250-mid');
   });</script></div>				</div>




				<div class="span12 span6-tablet">
					<div class="popular">
	<h5 class="block-title">Popular</h5>
	<ul class="story-list with-thumbs">
<li class="story">
	<a class="story-image" href="https://q13fox.com/2019/12/13/bath-body-works-having-huge-sale-saturday-thats-bigger-better-than-candle-day/"><img width="109" height="60" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" class="attachment-tiny-thumbnail size-tiny-thumbnail wp-post-image" alt data-lazy-src="https://tribkcpq.files.wordpress.com/2019/12/bath.jpg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1" data-lazy-srcset="https://tribkcpq.files.wordpress.com/2019/12/bath.jpg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1 109w, https://tribkcpq.files.wordpress.com/2019/12/bath.jpg?quality=85&amp;strip=all&amp;w=218&amp;h=120&amp;crop=1 218w, https://tribkcpq.files.wordpress.com/2019/12/bath.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w" data-lazy-sizes="(max-width: 109px) 100vw, 109px"><noscript><img width="109" height="60" src="https://tribkcpq.files.wordpress.com/2019/12/bath.jpg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1" class="attachment-tiny-thumbnail size-tiny-thumbnail wp-post-image" alt="" srcset="https://tribkcpq.files.wordpress.com/2019/12/bath.jpg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1 109w, https://tribkcpq.files.wordpress.com/2019/12/bath.jpg?quality=85&amp;strip=all&amp;w=218&amp;h=120&amp;crop=1 218w, https://tribkcpq.files.wordpress.com/2019/12/bath.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w" sizes="(max-width: 109px) 100vw, 109px" /></noscript></a>
	<strong class="entry-title"><a href="https://q13fox.com/2019/12/13/bath-body-works-having-huge-sale-saturday-thats-bigger-better-than-candle-day/" rel="bookmark">Bath &amp; Body Works having huge sale Saturday that&#8217;s bigger, better than Candle&nbsp;Day</a></strong>
</li>
<li class="story">
	<a class="story-image" href="https://q13fox.com/2019/12/12/an-octopus-caught-a-bald-eagle-in-a-death-grip-thanks-to-some-salmon-farmers-the-eagle-survived/"><img width="109" height="60" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" class="attachment-tiny-thumbnail size-tiny-thumbnail wp-post-image" alt data-lazy-src="https://tribkcpq.files.wordpress.com/2019/12/hypatia-h_26cc95427fe7ce0a6dba28923e5734a9-h_3bb8103cbd70f775a4e54b2e35b0f3e9.jpg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1" data-lazy-srcset="https://tribkcpq.files.wordpress.com/2019/12/hypatia-h_26cc95427fe7ce0a6dba28923e5734a9-h_3bb8103cbd70f775a4e54b2e35b0f3e9.jpg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1 109w, https://tribkcpq.files.wordpress.com/2019/12/hypatia-h_26cc95427fe7ce0a6dba28923e5734a9-h_3bb8103cbd70f775a4e54b2e35b0f3e9.jpg?quality=85&amp;strip=all&amp;w=218&amp;h=120&amp;crop=1 218w, https://tribkcpq.files.wordpress.com/2019/12/hypatia-h_26cc95427fe7ce0a6dba28923e5734a9-h_3bb8103cbd70f775a4e54b2e35b0f3e9.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w" data-lazy-sizes="(max-width: 109px) 100vw, 109px"><noscript><img width="109" height="60" src="https://tribkcpq.files.wordpress.com/2019/12/hypatia-h_26cc95427fe7ce0a6dba28923e5734a9-h_3bb8103cbd70f775a4e54b2e35b0f3e9.jpg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1" class="attachment-tiny-thumbnail size-tiny-thumbnail wp-post-image" alt="" srcset="https://tribkcpq.files.wordpress.com/2019/12/hypatia-h_26cc95427fe7ce0a6dba28923e5734a9-h_3bb8103cbd70f775a4e54b2e35b0f3e9.jpg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1 109w, https://tribkcpq.files.wordpress.com/2019/12/hypatia-h_26cc95427fe7ce0a6dba28923e5734a9-h_3bb8103cbd70f775a4e54b2e35b0f3e9.jpg?quality=85&amp;strip=all&amp;w=218&amp;h=120&amp;crop=1 218w, https://tribkcpq.files.wordpress.com/2019/12/hypatia-h_26cc95427fe7ce0a6dba28923e5734a9-h_3bb8103cbd70f775a4e54b2e35b0f3e9.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w" sizes="(max-width: 109px) 100vw, 109px" /></noscript></a>
	<strong class="entry-title"><a href="https://q13fox.com/2019/12/12/an-octopus-caught-a-bald-eagle-in-a-death-grip-thanks-to-some-salmon-farmers-the-eagle-survived/" rel="bookmark">An octopus caught a bald eagle in a death grip. Thanks to some salmon farmers, the eagle&nbsp;survived</a></strong>
</li>
<li class="story has-video">
	<a class="story-image" href="https://q13fox.com/2019/12/11/he-was-our-baby-family-devastated-after-veterinarian-euthanizes-wrong-dog/"><img width="109" height="60" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" class="attachment-tiny-thumbnail size-tiny-thumbnail wp-post-image" alt data-lazy-src="https://tribkcpq.files.wordpress.com/2019/12/ziggy-good2.jpg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1" data-lazy-srcset="https://tribkcpq.files.wordpress.com/2019/12/ziggy-good2.jpg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1 109w, https://tribkcpq.files.wordpress.com/2019/12/ziggy-good2.jpg?quality=85&amp;strip=all&amp;w=218&amp;h=120&amp;crop=1 218w, https://tribkcpq.files.wordpress.com/2019/12/ziggy-good2.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w" data-lazy-sizes="(max-width: 109px) 100vw, 109px"><noscript><img width="109" height="60" src="https://tribkcpq.files.wordpress.com/2019/12/ziggy-good2.jpg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1" class="attachment-tiny-thumbnail size-tiny-thumbnail wp-post-image" alt="" srcset="https://tribkcpq.files.wordpress.com/2019/12/ziggy-good2.jpg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1 109w, https://tribkcpq.files.wordpress.com/2019/12/ziggy-good2.jpg?quality=85&amp;strip=all&amp;w=218&amp;h=120&amp;crop=1 218w, https://tribkcpq.files.wordpress.com/2019/12/ziggy-good2.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w" sizes="(max-width: 109px) 100vw, 109px" /></noscript></a>
	<strong class="entry-title"><a href="https://q13fox.com/2019/12/11/he-was-our-baby-family-devastated-after-veterinarian-euthanizes-wrong-dog/" rel="bookmark">&#8216;He was our baby&#8217;: Family devastated after veterinarian euthanizes wrong&nbsp;dog</a></strong>
</li>
<li class="story has-video">
	<a class="story-image" href="https://q13fox.com/2019/12/11/kent-police-dangerous-sex-offender-wanted-in-home-break-in-that-terrified-13-year-old-girl/"><img width="109" height="60" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" class="attachment-tiny-thumbnail size-tiny-thumbnail wp-post-image" alt data-lazy-src="https://tribkcpq.files.wordpress.com/2019/12/kent-suspect.jpeg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1" data-lazy-srcset="https://tribkcpq.files.wordpress.com/2019/12/kent-suspect.jpeg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1 109w, https://tribkcpq.files.wordpress.com/2019/12/kent-suspect.jpeg?quality=85&amp;strip=all&amp;w=218&amp;h=120&amp;crop=1 218w, https://tribkcpq.files.wordpress.com/2019/12/kent-suspect.jpeg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w" data-lazy-sizes="(max-width: 109px) 100vw, 109px"><noscript><img width="109" height="60" src="https://tribkcpq.files.wordpress.com/2019/12/kent-suspect.jpeg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1" class="attachment-tiny-thumbnail size-tiny-thumbnail wp-post-image" alt="" srcset="https://tribkcpq.files.wordpress.com/2019/12/kent-suspect.jpeg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1 109w, https://tribkcpq.files.wordpress.com/2019/12/kent-suspect.jpeg?quality=85&amp;strip=all&amp;w=218&amp;h=120&amp;crop=1 218w, https://tribkcpq.files.wordpress.com/2019/12/kent-suspect.jpeg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w" sizes="(max-width: 109px) 100vw, 109px" /></noscript></a>
	<strong class="entry-title"><a href="https://q13fox.com/2019/12/11/kent-police-dangerous-sex-offender-wanted-in-home-break-in-that-terrified-13-year-old-girl/" rel="bookmark">Kent Police: Dangerous sex offender wanted in home break-in that terrified 13-year-old&nbsp;girl</a></strong>
</li>
	</ul>
</div>
				</div>

						</div>

			<div class="row-fluid">

				<div class="ad border-bottom span12 span6-tablet">
					<div id='acm-tag-300x250-btf' class='prebid ad-wrapper' style='width:300px; min-height: 250px;'><script>
googletag.cmd.push(function() {
    googletag.display('acm-tag-300x250-btf');
   });</script></div>				</div>


				<div class="span12 span6-tablet">
					<div class="latest">
	<h5 class="block-title">Latest News</h5>
	<ul class="story-list with-thumbs">

				
			  <li class="story has-video">
	<a class="story-image" href="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/"><img width="109" height="60" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" class="attachment-tiny-thumbnail size-tiny-thumbnail wp-post-image" alt data-lazy-src="https://tribkcpq.files.wordpress.com/2019/12/stabbing.jpg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1" data-lazy-srcset="https://tribkcpq.files.wordpress.com/2019/12/stabbing.jpg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1 109w, https://tribkcpq.files.wordpress.com/2019/12/stabbing.jpg?quality=85&amp;strip=all&amp;w=218&amp;h=120&amp;crop=1 218w, https://tribkcpq.files.wordpress.com/2019/12/stabbing.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w" data-lazy-sizes="(max-width: 109px) 100vw, 109px"><noscript><img width="109" height="60" src="https://tribkcpq.files.wordpress.com/2019/12/stabbing.jpg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1" class="attachment-tiny-thumbnail size-tiny-thumbnail wp-post-image" alt="" srcset="https://tribkcpq.files.wordpress.com/2019/12/stabbing.jpg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1 109w, https://tribkcpq.files.wordpress.com/2019/12/stabbing.jpg?quality=85&amp;strip=all&amp;w=218&amp;h=120&amp;crop=1 218w, https://tribkcpq.files.wordpress.com/2019/12/stabbing.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w" sizes="(max-width: 109px) 100vw, 109px" /></noscript></a>
	<strong class="entry-title"><a href="https://q13fox.com/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/" rel="bookmark">&#8216;There must be something wrong with him:&#8217; Stabbing victim, detectives hope you can help ID random street attack&nbsp;suspect</a></strong>
</li>

		
			  <li class="story has-video">
	<a class="story-image" href="https://q13fox.com/2019/12/13/drier-cooler-weather-ahead-this-weekend/"><img width="109" height="60" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" class="attachment-tiny-thumbnail size-tiny-thumbnail wp-post-image" alt data-lazy-src="https://tribkcpq.files.wordpress.com/2019/12/erin-pm-quickcast-2019.png?w=109&amp;h=60&amp;crop=1" data-lazy-srcset="https://tribkcpq.files.wordpress.com/2019/12/erin-pm-quickcast-2019.png?w=109&amp;h=60&amp;crop=1 109w, https://tribkcpq.files.wordpress.com/2019/12/erin-pm-quickcast-2019.png?w=218&amp;h=120&amp;crop=1 218w, https://tribkcpq.files.wordpress.com/2019/12/erin-pm-quickcast-2019.png?w=150&amp;h=83&amp;crop=1 150w" data-lazy-sizes="(max-width: 109px) 100vw, 109px"><noscript><img width="109" height="60" src="https://tribkcpq.files.wordpress.com/2019/12/erin-pm-quickcast-2019.png?w=109&amp;h=60&amp;crop=1" class="attachment-tiny-thumbnail size-tiny-thumbnail wp-post-image" alt="" srcset="https://tribkcpq.files.wordpress.com/2019/12/erin-pm-quickcast-2019.png?w=109&amp;h=60&amp;crop=1 109w, https://tribkcpq.files.wordpress.com/2019/12/erin-pm-quickcast-2019.png?w=218&amp;h=120&amp;crop=1 218w, https://tribkcpq.files.wordpress.com/2019/12/erin-pm-quickcast-2019.png?w=150&amp;h=83&amp;crop=1 150w" sizes="(max-width: 109px) 100vw, 109px" /></noscript></a>
	<strong class="entry-title"><a href="https://q13fox.com/2019/12/13/drier-cooler-weather-ahead-this-weekend/" rel="bookmark">Drier, cooler weather ahead this&nbsp;weekend</a></strong>
</li>

		
			  <li class="story has-video">
	<a class="story-image" href="https://q13fox.com/2019/12/13/liquid-meth-found-inside-transmission-fluid-coolant-containers/"><img width="109" height="60" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" class="attachment-tiny-thumbnail size-tiny-thumbnail wp-post-image" alt data-lazy-src="https://tribkcpq.files.wordpress.com/2019/12/12-12-19-agents-arrest-man-smuggling-meth-on-i-5_photo-1.jpg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1" data-lazy-srcset="https://tribkcpq.files.wordpress.com/2019/12/12-12-19-agents-arrest-man-smuggling-meth-on-i-5_photo-1.jpg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1 109w, https://tribkcpq.files.wordpress.com/2019/12/12-12-19-agents-arrest-man-smuggling-meth-on-i-5_photo-1.jpg?quality=85&amp;strip=all&amp;w=218&amp;h=120&amp;crop=1 218w, https://tribkcpq.files.wordpress.com/2019/12/12-12-19-agents-arrest-man-smuggling-meth-on-i-5_photo-1.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w" data-lazy-sizes="(max-width: 109px) 100vw, 109px"><noscript><img width="109" height="60" src="https://tribkcpq.files.wordpress.com/2019/12/12-12-19-agents-arrest-man-smuggling-meth-on-i-5_photo-1.jpg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1" class="attachment-tiny-thumbnail size-tiny-thumbnail wp-post-image" alt="" srcset="https://tribkcpq.files.wordpress.com/2019/12/12-12-19-agents-arrest-man-smuggling-meth-on-i-5_photo-1.jpg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1 109w, https://tribkcpq.files.wordpress.com/2019/12/12-12-19-agents-arrest-man-smuggling-meth-on-i-5_photo-1.jpg?quality=85&amp;strip=all&amp;w=218&amp;h=120&amp;crop=1 218w, https://tribkcpq.files.wordpress.com/2019/12/12-12-19-agents-arrest-man-smuggling-meth-on-i-5_photo-1.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w" sizes="(max-width: 109px) 100vw, 109px" /></noscript></a>
	<strong class="entry-title"><a href="https://q13fox.com/2019/12/13/liquid-meth-found-inside-transmission-fluid-coolant-containers/" rel="bookmark">Liquid meth found inside transmission fluid, coolant&nbsp;containers</a></strong>
</li>

		
			  <li class="story">
	<a class="story-image" href="https://q13fox.com/2019/12/13/edward-beaulieu-wanted-gardner-charged-with-touching-young-girl-sexually-while-doing-work-for-her-mom/"><img width="109" height="60" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" class="attachment-tiny-thumbnail size-tiny-thumbnail wp-post-image" alt data-lazy-src="https://tribkcpq.files.wordpress.com/2019/12/ed.jpg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1" data-lazy-srcset="https://tribkcpq.files.wordpress.com/2019/12/ed.jpg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1 109w, https://tribkcpq.files.wordpress.com/2019/12/ed.jpg?quality=85&amp;strip=all&amp;w=218&amp;h=120&amp;crop=1 218w, https://tribkcpq.files.wordpress.com/2019/12/ed.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w" data-lazy-sizes="(max-width: 109px) 100vw, 109px"><noscript><img width="109" height="60" src="https://tribkcpq.files.wordpress.com/2019/12/ed.jpg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1" class="attachment-tiny-thumbnail size-tiny-thumbnail wp-post-image" alt="" srcset="https://tribkcpq.files.wordpress.com/2019/12/ed.jpg?quality=85&amp;strip=all&amp;w=109&amp;h=60&amp;crop=1 109w, https://tribkcpq.files.wordpress.com/2019/12/ed.jpg?quality=85&amp;strip=all&amp;w=218&amp;h=120&amp;crop=1 218w, https://tribkcpq.files.wordpress.com/2019/12/ed.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w" sizes="(max-width: 109px) 100vw, 109px" /></noscript></a>
	<strong class="entry-title"><a href="https://q13fox.com/2019/12/13/edward-beaulieu-wanted-gardner-charged-with-touching-young-girl-sexually-while-doing-work-for-her-mom/" rel="bookmark">Edward Beaulieu: Wanted gardner charged with touching young girl sexually while doing work for her&nbsp;mom</a></strong>
</li>

		
		</ul>
</div>
				</div>

				<div class="ad border-bottom span12 span6-tablet">
					<div id='acm-tag-300x250-btf1' class='prebid ad-wrapper' style='width:300px; min-height: 250px;'><script>
googletag.cmd.push(function() {
    googletag.display('acm-tag-300x250-btf1');
   });</script></div>				</div>

				<div class="span12 span6-tablet">

		<div id="civicscience-widget">
			<div id="153d2462-6d40-4334-adae-8631152c432a"></div>
			<script src="https://www.civicscience.com/widget/jspoll/?elt=153d2462-6d40-4334-adae-8631152c432a&#038;tgt=2296" async defer></script></div>				</div>

			</div>
		</div>
	  </div>
        </div>
    <div class="full-width">
      <div class="container">
        <div class="row">
          <div class="span12">
                        <ul id="stories-infinite" class="story-grid thumbnails">
              		<li class="story span4 span6-tablet has-video">
  	<div class="extra"><a href="https://q13fox.com/category/news/crime/" title="View all posts in Crime">Crime</a> <a href="https://q13fox.com/category/news/" title="View all posts in News">News</a></div>
	
		<a class="story-image" href="https://q13fox.com/2019/11/27/suspect-arrested-after-brutal-random-attack-outside-king-co-courthouse/"><img width="370" height="204" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt data-lazy-src="https://tribkcpq.files.wordpress.com/2019/11/attack.png?w=370&amp;h=204&amp;crop=1" data-lazy-srcset="https://tribkcpq.files.wordpress.com/2019/11/attack.png?w=370&amp;h=204&amp;crop=1 370w, https://tribkcpq.files.wordpress.com/2019/11/attack.png?w=740&amp;h=408&amp;crop=1 740w, https://tribkcpq.files.wordpress.com/2019/11/attack.png?w=150&amp;h=83&amp;crop=1 150w, https://tribkcpq.files.wordpress.com/2019/11/attack.png?w=300&amp;h=166&amp;crop=1 300w" data-lazy-sizes="(max-width: 370px) 100vw, 370px"><noscript><img width="370" height="204" src="https://tribkcpq.files.wordpress.com/2019/11/attack.png?w=370&amp;h=204&amp;crop=1" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt="" srcset="https://tribkcpq.files.wordpress.com/2019/11/attack.png?w=370&amp;h=204&amp;crop=1 370w, https://tribkcpq.files.wordpress.com/2019/11/attack.png?w=740&amp;h=408&amp;crop=1 740w, https://tribkcpq.files.wordpress.com/2019/11/attack.png?w=150&amp;h=83&amp;crop=1 150w, https://tribkcpq.files.wordpress.com/2019/11/attack.png?w=300&amp;h=166&amp;crop=1 300w" sizes="(max-width: 370px) 100vw, 370px" /></noscript></a>
	<h4 class="entry-title"><a href="https://q13fox.com/2019/11/27/suspect-arrested-after-brutal-random-attack-outside-king-co-courthouse/" rel="bookmark">Suspect arrested after brutal, random attack outside King Co.&nbsp;Courthouse</a></h4>
</li>
		
	<li class="story span4 span6-tablet has-video">
  	<div class="extra"><a href="https://q13fox.com/category/washingtons-most-wanted/" title="View all posts in Washington&#039;s Most Wanted">Washington&#039;s Most Wanted</a></div>
	
		<a class="story-image" href="https://q13fox.com/2019/09/20/the-hits-just-kept-coming-and-coming-and-coming-help-id-assault-suspect-who-used-flowers-to-lure-victim-into-vicious-attack/"><img width="294" height="204" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt data-lazy-src="https://tribkcpq.files.wordpress.com/2019/09/seattle-attack-suspect.jpg?quality=85&amp;strip=all&amp;w=294&amp;h=204&amp;crop=1" data-lazy-srcset="https://tribkcpq.files.wordpress.com/2019/09/seattle-attack-suspect.jpg?quality=85&amp;strip=all&amp;w=294&amp;h=204&amp;crop=1 294w, https://tribkcpq.files.wordpress.com/2019/09/seattle-attack-suspect.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=104&amp;crop=1 150w" data-lazy-sizes="(max-width: 294px) 100vw, 294px"><noscript><img width="294" height="204" src="https://tribkcpq.files.wordpress.com/2019/09/seattle-attack-suspect.jpg?quality=85&amp;strip=all&amp;w=294&amp;h=204&amp;crop=1" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt="" srcset="https://tribkcpq.files.wordpress.com/2019/09/seattle-attack-suspect.jpg?quality=85&amp;strip=all&amp;w=294&amp;h=204&amp;crop=1 294w, https://tribkcpq.files.wordpress.com/2019/09/seattle-attack-suspect.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=104&amp;crop=1 150w" sizes="(max-width: 294px) 100vw, 294px" /></noscript></a>
	<h4 class="entry-title"><a href="https://q13fox.com/2019/09/20/the-hits-just-kept-coming-and-coming-and-coming-help-id-assault-suspect-who-used-flowers-to-lure-victim-into-vicious-attack/" rel="bookmark">&#8220;The hits just kept coming and coming and coming:&#8221; Help ID assault suspect who used flowers to lure victim into vicious&nbsp;attack</a></h4>
</li>
		
	<li class="story span4 span6-tablet has-video">
  	<div class="extra"><a href="https://q13fox.com/category/washingtons-most-wanted/" title="View all posts in Washington&#039;s Most Wanted">Washington&#039;s Most Wanted</a></div>
	
		<div class="timestamp">
		2 hours ago	</div>
		<a class="story-image" href="https://q13fox.com/2019/12/13/cencere-saunders-16-year-old-shooting-suspect-with-slew-of-convictions-accused-of-setting-up-robbery-through-online-buy/"><img width="370" height="204" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt data-lazy-src="https://tribkcpq.files.wordpress.com/2019/12/saunders.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1" data-lazy-srcset="https://tribkcpq.files.wordpress.com/2019/12/saunders.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1 370w, https://tribkcpq.files.wordpress.com/2019/12/saunders.jpg?quality=85&amp;strip=all&amp;w=740&amp;h=408&amp;crop=1 740w, https://tribkcpq.files.wordpress.com/2019/12/saunders.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w, https://tribkcpq.files.wordpress.com/2019/12/saunders.jpg?quality=85&amp;strip=all&amp;w=300&amp;h=165&amp;crop=1 300w" data-lazy-sizes="(max-width: 370px) 100vw, 370px"><noscript><img width="370" height="204" src="https://tribkcpq.files.wordpress.com/2019/12/saunders.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt="" srcset="https://tribkcpq.files.wordpress.com/2019/12/saunders.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1 370w, https://tribkcpq.files.wordpress.com/2019/12/saunders.jpg?quality=85&amp;strip=all&amp;w=740&amp;h=408&amp;crop=1 740w, https://tribkcpq.files.wordpress.com/2019/12/saunders.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w, https://tribkcpq.files.wordpress.com/2019/12/saunders.jpg?quality=85&amp;strip=all&amp;w=300&amp;h=165&amp;crop=1 300w" sizes="(max-width: 370px) 100vw, 370px" /></noscript></a>
	<h4 class="entry-title"><a href="https://q13fox.com/2019/12/13/cencere-saunders-16-year-old-shooting-suspect-with-slew-of-convictions-accused-of-setting-up-robbery-through-online-buy/" rel="bookmark">Cencere Saunders: 16 year old shooting suspect with slew of convictions accused of setting-up robbery through online&nbsp;buy</a></h4>
</li>
		
	<li class="story span4 span6-tablet has-video">
  	<div class="extra"><a href="https://q13fox.com/category/news/" title="View all posts in News">News</a> <a href="https://q13fox.com/category/washingtons-most-wanted/" title="View all posts in Washington&#039;s Most Wanted">Washington&#039;s Most Wanted</a></div>
	
		<a class="story-image" href="https://q13fox.com/2019/09/06/help-id-crowbar-wielding-pharmacy-robber-seen-well-on-surveillance-video/"><img width="370" height="204" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt data-lazy-src="https://tribkcpq.files.wordpress.com/2019/09/rx.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1" data-lazy-srcset="https://tribkcpq.files.wordpress.com/2019/09/rx.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1 370w, https://tribkcpq.files.wordpress.com/2019/09/rx.jpg?quality=85&amp;strip=all&amp;w=740&amp;h=408&amp;crop=1 740w, https://tribkcpq.files.wordpress.com/2019/09/rx.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w, https://tribkcpq.files.wordpress.com/2019/09/rx.jpg?quality=85&amp;strip=all&amp;w=300&amp;h=165&amp;crop=1 300w" data-lazy-sizes="(max-width: 370px) 100vw, 370px"><noscript><img width="370" height="204" src="https://tribkcpq.files.wordpress.com/2019/09/rx.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt="" srcset="https://tribkcpq.files.wordpress.com/2019/09/rx.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1 370w, https://tribkcpq.files.wordpress.com/2019/09/rx.jpg?quality=85&amp;strip=all&amp;w=740&amp;h=408&amp;crop=1 740w, https://tribkcpq.files.wordpress.com/2019/09/rx.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w, https://tribkcpq.files.wordpress.com/2019/09/rx.jpg?quality=85&amp;strip=all&amp;w=300&amp;h=165&amp;crop=1 300w" sizes="(max-width: 370px) 100vw, 370px" /></noscript></a>
	<h4 class="entry-title"><a href="https://q13fox.com/2019/09/06/help-id-crowbar-wielding-pharmacy-robber-seen-well-on-surveillance-video/" rel="bookmark">Help ID crowbar-wielding pharmacy robber caught on surveillance&nbsp;video</a></h4>
</li>
		
	<li class="story span4 span6-tablet has-video">
  	<div class="extra"><a href="https://q13fox.com/category/washingtons-most-wanted/" title="View all posts in Washington&#039;s Most Wanted">Washington&#039;s Most Wanted</a></div>
	
		<a class="story-image" href="https://q13fox.com/2019/10/25/help-id-crew-of-crooks-who-violently-assaulted-store-clerk-for-cash-and-cigarettes/"><img width="370" height="204" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt data-lazy-src="https://tribkcpq.files.wordpress.com/2019/10/cheap-smokes2.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1" data-lazy-srcset="https://tribkcpq.files.wordpress.com/2019/10/cheap-smokes2.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1 370w, https://tribkcpq.files.wordpress.com/2019/10/cheap-smokes2.jpg?quality=85&amp;strip=all&amp;w=740&amp;h=408&amp;crop=1 740w, https://tribkcpq.files.wordpress.com/2019/10/cheap-smokes2.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w, https://tribkcpq.files.wordpress.com/2019/10/cheap-smokes2.jpg?quality=85&amp;strip=all&amp;w=300&amp;h=165&amp;crop=1 300w" data-lazy-sizes="(max-width: 370px) 100vw, 370px"><noscript><img width="370" height="204" src="https://tribkcpq.files.wordpress.com/2019/10/cheap-smokes2.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt="" srcset="https://tribkcpq.files.wordpress.com/2019/10/cheap-smokes2.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1 370w, https://tribkcpq.files.wordpress.com/2019/10/cheap-smokes2.jpg?quality=85&amp;strip=all&amp;w=740&amp;h=408&amp;crop=1 740w, https://tribkcpq.files.wordpress.com/2019/10/cheap-smokes2.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w, https://tribkcpq.files.wordpress.com/2019/10/cheap-smokes2.jpg?quality=85&amp;strip=all&amp;w=300&amp;h=165&amp;crop=1 300w" sizes="(max-width: 370px) 100vw, 370px" /></noscript></a>
	<h4 class="entry-title"><a href="https://q13fox.com/2019/10/25/help-id-crew-of-crooks-who-violently-assaulted-store-clerk-for-cash-and-cigarettes/" rel="bookmark">Help ID crew of crooks who violently assaulted store clerk for cash and&nbsp;cigarettes</a></h4>
</li>
					<li class="span4 span6-tablet">
						<div class="ad">
							<div id='acm-tag-300x250-btf2' class='prebid ad-wrapper' style='width:300px; min-height: 250px;'><script>
googletag.cmd.push(function() {
    googletag.display('acm-tag-300x250-btf2');
   });</script></div>						</div>
					</li>
		
	<li class="story span4 span6-tablet has-video">
  	<div class="extra"><a href="https://q13fox.com/category/news/" title="View all posts in News">News</a></div>
	
		<a class="story-image" href="https://q13fox.com/2019/11/12/felon-accused-of-murdering-beloved-lakewood-convenience-store-owner/"><img width="370" height="204" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt data-lazy-src="https://tribkcpq.files.wordpress.com/2019/11/williwams.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1" data-lazy-srcset="https://tribkcpq.files.wordpress.com/2019/11/williwams.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1 370w, https://tribkcpq.files.wordpress.com/2019/11/williwams.jpg?quality=85&amp;strip=all&amp;w=740&amp;h=408&amp;crop=1 740w, https://tribkcpq.files.wordpress.com/2019/11/williwams.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w, https://tribkcpq.files.wordpress.com/2019/11/williwams.jpg?quality=85&amp;strip=all&amp;w=300&amp;h=165&amp;crop=1 300w" data-lazy-sizes="(max-width: 370px) 100vw, 370px"><noscript><img width="370" height="204" src="https://tribkcpq.files.wordpress.com/2019/11/williwams.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt="" srcset="https://tribkcpq.files.wordpress.com/2019/11/williwams.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1 370w, https://tribkcpq.files.wordpress.com/2019/11/williwams.jpg?quality=85&amp;strip=all&amp;w=740&amp;h=408&amp;crop=1 740w, https://tribkcpq.files.wordpress.com/2019/11/williwams.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w, https://tribkcpq.files.wordpress.com/2019/11/williwams.jpg?quality=85&amp;strip=all&amp;w=300&amp;h=165&amp;crop=1 300w" sizes="(max-width: 370px) 100vw, 370px" /></noscript></a>
	<h4 class="entry-title"><a href="https://q13fox.com/2019/11/12/felon-accused-of-murdering-beloved-lakewood-convenience-store-owner/" rel="bookmark">Felon accused of murdering beloved Lakewood convenience store&nbsp;owner</a></h4>
</li>
		
	<li class="story span4 span6-tablet has-video">
  	<div class="extra"><a href="https://q13fox.com/category/news/" title="View all posts in News">News</a> <a href="https://q13fox.com/category/washingtons-most-wanted/" title="View all posts in Washington&#039;s Most Wanted">Washington&#039;s Most Wanted</a></div>
	
		<a class="story-image" href="https://q13fox.com/2019/09/27/help-id-armed-crew-of-accused-street-robbers-who-stole-mans-phone-keys-and-cash/"><img width="370" height="204" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt data-lazy-src="https://tribkcpq.files.wordpress.com/2019/09/street.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1" data-lazy-srcset="https://tribkcpq.files.wordpress.com/2019/09/street.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1 370w, https://tribkcpq.files.wordpress.com/2019/09/street.jpg?quality=85&amp;strip=all&amp;w=740&amp;h=408&amp;crop=1 740w, https://tribkcpq.files.wordpress.com/2019/09/street.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w, https://tribkcpq.files.wordpress.com/2019/09/street.jpg?quality=85&amp;strip=all&amp;w=300&amp;h=165&amp;crop=1 300w" data-lazy-sizes="(max-width: 370px) 100vw, 370px"><noscript><img width="370" height="204" src="https://tribkcpq.files.wordpress.com/2019/09/street.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt="" srcset="https://tribkcpq.files.wordpress.com/2019/09/street.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1 370w, https://tribkcpq.files.wordpress.com/2019/09/street.jpg?quality=85&amp;strip=all&amp;w=740&amp;h=408&amp;crop=1 740w, https://tribkcpq.files.wordpress.com/2019/09/street.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w, https://tribkcpq.files.wordpress.com/2019/09/street.jpg?quality=85&amp;strip=all&amp;w=300&amp;h=165&amp;crop=1 300w" sizes="(max-width: 370px) 100vw, 370px" /></noscript></a>
	<h4 class="entry-title"><a href="https://q13fox.com/2019/09/27/help-id-armed-crew-of-accused-street-robbers-who-stole-mans-phone-keys-and-cash/" rel="bookmark">Help ID armed crew of accused street robbers who stole man&#8217;s phone, keys and&nbsp;cash</a></h4>
</li>
		
	<li class="story span4 span6-tablet has-video">
  	<div class="extra"><a href="https://q13fox.com/category/washingtons-most-wanted/" title="View all posts in Washington&#039;s Most Wanted">Washington&#039;s Most Wanted</a></div>
	
		<a class="story-image" href="https://q13fox.com/2019/10/24/reward-offered-to-help-cops-identify-serial-armed-robbers-in-seattle/"><img width="370" height="204" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt data-lazy-src="https://tribkcpq.files.wordpress.com/2019/10/promo396217101.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1" data-lazy-srcset="https://tribkcpq.files.wordpress.com/2019/10/promo396217101.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1 370w, https://tribkcpq.files.wordpress.com/2019/10/promo396217101.jpg?quality=85&amp;strip=all&amp;w=740&amp;h=408&amp;crop=1 740w, https://tribkcpq.files.wordpress.com/2019/10/promo396217101.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w, https://tribkcpq.files.wordpress.com/2019/10/promo396217101.jpg?quality=85&amp;strip=all&amp;w=300&amp;h=165&amp;crop=1 300w" data-lazy-sizes="(max-width: 370px) 100vw, 370px"><noscript><img width="370" height="204" src="https://tribkcpq.files.wordpress.com/2019/10/promo396217101.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt="" srcset="https://tribkcpq.files.wordpress.com/2019/10/promo396217101.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1 370w, https://tribkcpq.files.wordpress.com/2019/10/promo396217101.jpg?quality=85&amp;strip=all&amp;w=740&amp;h=408&amp;crop=1 740w, https://tribkcpq.files.wordpress.com/2019/10/promo396217101.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w, https://tribkcpq.files.wordpress.com/2019/10/promo396217101.jpg?quality=85&amp;strip=all&amp;w=300&amp;h=165&amp;crop=1 300w" sizes="(max-width: 370px) 100vw, 370px" /></noscript></a>
	<h4 class="entry-title"><a href="https://q13fox.com/2019/10/24/reward-offered-to-help-cops-identify-serial-armed-robbers-in-seattle/" rel="bookmark">Reward offered to help cops identify serial armed robbers in&nbsp;Seattle</a></h4>
</li>
		
	<li class="story span4 span6-tablet has-video">
  	<div class="extra"><a href="https://q13fox.com/category/washingtons-most-wanted/" title="View all posts in Washington&#039;s Most Wanted">Washington&#039;s Most Wanted</a></div>
	
		<a class="story-image" href="https://q13fox.com/2019/10/04/help-id-shooting-suspect-who-opened-fire-in-city-park-shot-man-in-leg/"><img width="370" height="204" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt data-lazy-src="https://tribkcpq.files.wordpress.com/2019/10/prefontaine.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1" data-lazy-srcset="https://tribkcpq.files.wordpress.com/2019/10/prefontaine.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1 370w, https://tribkcpq.files.wordpress.com/2019/10/prefontaine.jpg?quality=85&amp;strip=all&amp;w=740&amp;h=408&amp;crop=1 740w, https://tribkcpq.files.wordpress.com/2019/10/prefontaine.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w, https://tribkcpq.files.wordpress.com/2019/10/prefontaine.jpg?quality=85&amp;strip=all&amp;w=300&amp;h=165&amp;crop=1 300w" data-lazy-sizes="(max-width: 370px) 100vw, 370px"><noscript><img width="370" height="204" src="https://tribkcpq.files.wordpress.com/2019/10/prefontaine.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt="" srcset="https://tribkcpq.files.wordpress.com/2019/10/prefontaine.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1 370w, https://tribkcpq.files.wordpress.com/2019/10/prefontaine.jpg?quality=85&amp;strip=all&amp;w=740&amp;h=408&amp;crop=1 740w, https://tribkcpq.files.wordpress.com/2019/10/prefontaine.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w, https://tribkcpq.files.wordpress.com/2019/10/prefontaine.jpg?quality=85&amp;strip=all&amp;w=300&amp;h=165&amp;crop=1 300w" sizes="(max-width: 370px) 100vw, 370px" /></noscript></a>
	<h4 class="entry-title"><a href="https://q13fox.com/2019/10/04/help-id-shooting-suspect-who-opened-fire-in-city-park-shot-man-in-leg/" rel="bookmark">Help ID shooting suspect who opened fire in city park, shot man in&nbsp;leg</a></h4>
</li>
		
	<li class="story span4 span6-tablet has-video">
  	<div class="extra"><a href="https://q13fox.com/category/news/crime/" title="View all posts in Crime">Crime</a> <a href="https://q13fox.com/category/news/" title="View all posts in News">News</a> <a href="https://q13fox.com/category/washingtons-most-wanted/" title="View all posts in Washington&#039;s Most Wanted">Washington&#039;s Most Wanted</a></div>
	
		<a class="story-image" href="https://q13fox.com/2019/11/14/police-need-help-to-identify-suspect-in-deadly-seattle-shooting/"><img width="370" height="204" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt data-lazy-src="https://tribkcpq.files.wordpress.com/2019/11/promo398046504.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1" data-lazy-srcset="https://tribkcpq.files.wordpress.com/2019/11/promo398046504.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1 370w, https://tribkcpq.files.wordpress.com/2019/11/promo398046504.jpg?quality=85&amp;strip=all&amp;w=740&amp;h=408&amp;crop=1 740w, https://tribkcpq.files.wordpress.com/2019/11/promo398046504.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w, https://tribkcpq.files.wordpress.com/2019/11/promo398046504.jpg?quality=85&amp;strip=all&amp;w=300&amp;h=165&amp;crop=1 300w" data-lazy-sizes="(max-width: 370px) 100vw, 370px"><noscript><img width="370" height="204" src="https://tribkcpq.files.wordpress.com/2019/11/promo398046504.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt="" srcset="https://tribkcpq.files.wordpress.com/2019/11/promo398046504.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1 370w, https://tribkcpq.files.wordpress.com/2019/11/promo398046504.jpg?quality=85&amp;strip=all&amp;w=740&amp;h=408&amp;crop=1 740w, https://tribkcpq.files.wordpress.com/2019/11/promo398046504.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w, https://tribkcpq.files.wordpress.com/2019/11/promo398046504.jpg?quality=85&amp;strip=all&amp;w=300&amp;h=165&amp;crop=1 300w" sizes="(max-width: 370px) 100vw, 370px" /></noscript></a>
	<h4 class="entry-title"><a href="https://q13fox.com/2019/11/14/police-need-help-to-identify-suspect-in-deadly-seattle-shooting/" rel="bookmark">Police need help to identify suspect in deadly Seattle&nbsp;shooting</a></h4>
</li>
					<li class="span4 span6-tablet">
						<div class="ad">
							<div id='acm-tag-300x250-btf3' class='prebid ad-wrapper' style='width:300px; min-height: 250px;'><script>
googletag.cmd.push(function() {
    googletag.display('acm-tag-300x250-btf3');
   });</script></div>						</div>
					</li>
		
	<li class="story span4 span6-tablet has-video">
  	<div class="extra"><a href="https://q13fox.com/category/news/crime/" title="View all posts in Crime">Crime</a> <a href="https://q13fox.com/category/news/" title="View all posts in News">News</a> <a href="https://q13fox.com/category/washingtons-most-wanted/" title="View all posts in Washington&#039;s Most Wanted">Washington&#039;s Most Wanted</a></div>
	
		<a class="story-image" href="https://q13fox.com/2019/10/11/detectives-seek-id-of-suspect-who-crawled-into-casino-office-to-steal-more-than-13000/"><img width="370" height="204" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt data-lazy-src="https://tribkcpq.files.wordpress.com/2019/10/casino-suspect.jpeg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1" data-lazy-srcset="https://tribkcpq.files.wordpress.com/2019/10/casino-suspect.jpeg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1 370w, https://tribkcpq.files.wordpress.com/2019/10/casino-suspect.jpeg?quality=85&amp;strip=all&amp;w=740&amp;h=408&amp;crop=1 740w, https://tribkcpq.files.wordpress.com/2019/10/casino-suspect.jpeg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w, https://tribkcpq.files.wordpress.com/2019/10/casino-suspect.jpeg?quality=85&amp;strip=all&amp;w=300&amp;h=165&amp;crop=1 300w" data-lazy-sizes="(max-width: 370px) 100vw, 370px"><noscript><img width="370" height="204" src="https://tribkcpq.files.wordpress.com/2019/10/casino-suspect.jpeg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt="" srcset="https://tribkcpq.files.wordpress.com/2019/10/casino-suspect.jpeg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1 370w, https://tribkcpq.files.wordpress.com/2019/10/casino-suspect.jpeg?quality=85&amp;strip=all&amp;w=740&amp;h=408&amp;crop=1 740w, https://tribkcpq.files.wordpress.com/2019/10/casino-suspect.jpeg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w, https://tribkcpq.files.wordpress.com/2019/10/casino-suspect.jpeg?quality=85&amp;strip=all&amp;w=300&amp;h=165&amp;crop=1 300w" sizes="(max-width: 370px) 100vw, 370px" /></noscript></a>
	<h4 class="entry-title"><a href="https://q13fox.com/2019/10/11/detectives-seek-id-of-suspect-who-crawled-into-casino-office-to-steal-more-than-13000/" rel="bookmark">Detectives seek ID of suspect who crawled into casino office to steal more than&nbsp;$13,000</a></h4>
</li>
		
	<li class="story span4 span6-tablet has-video">
  	<div class="extra"><a href="https://q13fox.com/category/news/crime/" title="View all posts in Crime">Crime</a> <a href="https://q13fox.com/category/news/" title="View all posts in News">News</a> <a href="https://q13fox.com/category/washingtons-most-wanted/" title="View all posts in Washington&#039;s Most Wanted">Washington&#039;s Most Wanted</a></div>
	
		<a class="story-image" href="https://q13fox.com/2019/11/22/seattle-police-seek-id-of-couple-wanted-in-attempted-carjacking-at-gas-station/"><img width="370" height="204" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt data-lazy-src="https://tribkcpq.files.wordpress.com/2019/11/attempted-carjacking-suspect.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1" data-lazy-srcset="https://tribkcpq.files.wordpress.com/2019/11/attempted-carjacking-suspect.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1 370w, https://tribkcpq.files.wordpress.com/2019/11/attempted-carjacking-suspect.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w, https://tribkcpq.files.wordpress.com/2019/11/attempted-carjacking-suspect.jpg?quality=85&amp;strip=all&amp;w=300&amp;h=165&amp;crop=1 300w, https://tribkcpq.files.wordpress.com/2019/11/attempted-carjacking-suspect.jpg?quality=85&amp;strip=all 508w" data-lazy-sizes="(max-width: 370px) 100vw, 370px"><noscript><img width="370" height="204" src="https://tribkcpq.files.wordpress.com/2019/11/attempted-carjacking-suspect.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt="" srcset="https://tribkcpq.files.wordpress.com/2019/11/attempted-carjacking-suspect.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1 370w, https://tribkcpq.files.wordpress.com/2019/11/attempted-carjacking-suspect.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w, https://tribkcpq.files.wordpress.com/2019/11/attempted-carjacking-suspect.jpg?quality=85&amp;strip=all&amp;w=300&amp;h=165&amp;crop=1 300w, https://tribkcpq.files.wordpress.com/2019/11/attempted-carjacking-suspect.jpg?quality=85&amp;strip=all 508w" sizes="(max-width: 370px) 100vw, 370px" /></noscript></a>
	<h4 class="entry-title"><a href="https://q13fox.com/2019/11/22/seattle-police-seek-id-of-couple-wanted-in-attempted-carjacking-at-gas-station/" rel="bookmark">Seattle Police seek ID of couple wanted in attempted carjacking at gas&nbsp;station</a></h4>
</li>
		
	<li class="story span4 span6-tablet">
  	<div class="extra"><a href="https://q13fox.com/category/news/" title="View all posts in News">News</a> <a href="https://q13fox.com/category/washingtons-most-wanted/" title="View all posts in Washington&#039;s Most Wanted">Washington&#039;s Most Wanted</a></div>
	
		<a class="story-image" href="https://q13fox.com/2019/11/21/id-needed-of-wild-eyed-serial-armed-robbery-suspect/"><img width="370" height="204" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt data-lazy-src="https://tribkcpq.files.wordpress.com/2019/11/suspect-1-e1574356817996.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1" data-lazy-srcset="https://tribkcpq.files.wordpress.com/2019/11/suspect-1-e1574356817996.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1 370w, https://tribkcpq.files.wordpress.com/2019/11/suspect-1-e1574356817996.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w, https://tribkcpq.files.wordpress.com/2019/11/suspect-1-e1574356817996.jpg?quality=85&amp;strip=all&amp;w=300&amp;h=166&amp;crop=1 300w" data-lazy-sizes="(max-width: 370px) 100vw, 370px"><noscript><img width="370" height="204" src="https://tribkcpq.files.wordpress.com/2019/11/suspect-1-e1574356817996.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1" class="attachment-grid-thumbnail size-grid-thumbnail wp-post-image" alt="" srcset="https://tribkcpq.files.wordpress.com/2019/11/suspect-1-e1574356817996.jpg?quality=85&amp;strip=all&amp;w=370&amp;h=204&amp;crop=1 370w, https://tribkcpq.files.wordpress.com/2019/11/suspect-1-e1574356817996.jpg?quality=85&amp;strip=all&amp;w=150&amp;h=83&amp;crop=1 150w, https://tribkcpq.files.wordpress.com/2019/11/suspect-1-e1574356817996.jpg?quality=85&amp;strip=all&amp;w=300&amp;h=166&amp;crop=1 300w" sizes="(max-width: 370px) 100vw, 370px" /></noscript></a>
	<h4 class="entry-title"><a href="https://q13fox.com/2019/11/21/id-needed-of-wild-eyed-serial-armed-robbery-suspect/" rel="bookmark">ID needed of wild-eyed serial armed robbery&nbsp;suspect</a></h4>
</li>
		
	            </ul>
          </div>
        </div>
      </div>
    </div>
    <div class="container">	</div>
</div>
	<div class="ad ad-long full-width">
		<div id='acm-tag-728x90-btf' class='prebid ad-wrapper' style='width:px; min-height: 90px;'><script>
googletag.cmd.push(function() {
    googletag.display('acm-tag-728x90-btf');
   });</script></div>	</div>
	<footer role="contentinfo">

<div id="mobile-links" class="footer-block gray-links full-width"><ul id="menu-footer-app-links" class="nav nav-pills"><li class="nav-header">Mobile Apps</li><li id="menu-item-115240" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-115240"><a href="https://itunes.apple.com/us/app/q13-fox-news-seattle/id593634365?mt=8">News App (iOS)</a></li>
<li id="menu-item-115239" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-115239"><a href="https://play.google.com/store/apps/details?id=com.tribtv.kcpq">News App (Android)</a></li>
<li id="menu-item-168734" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-168734"><a href="https://itunes.apple.com/us/app/q13-fox-weather/id962146621?mt=8#">Weather App (iOS)</a></li>
<li id="menu-item-168735" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-168735"><a href="https://play.google.com/store/apps/details?id=com.kcpq.android.weather&#038;hl=en">Weather App (Android)</a></li>
</ul></div>
	<div id="extra-links" class="footer-block gray-links full-width">
		<div class="container">
			<ul class="nav nav-pills">
										<li>
							<a href="https://www.facebook.com/Q13FOX" target="_blank">
								<i class="icon-facebook-sign icon-4x"></i>Facebook							</a>
						</li>
															<li>
							<a href="https://twitter.com/q13fox" target="_blank">
								<i class="icon-twitter-sign icon-4x"></i>Twitter							</a>
						</li>
															<li>
							<a href="https://www.instagram.com/q13fox/" target="_blank">
								<i class="icon-instagram icon-4x"></i>Instagram							</a>
						</li>
									
										<li><a href="https://q13fox.com/email-alerts/" target="_blank"><i class="icon-envelope icon-4x"></i>Email Alerts</a></li>
									
								<li><a href="https://q13fox.com/aboutus/"><i class="icon-info-sign icon-4x"></i>About &amp; Contact</a></li>

				<li><a href="http://www.covers.com/" target="_blank">
					<svg xmlns="http://www.w3.org/2000/svg" width="50" height="50" viewBox="0 0 50 50"><path d="M45.2677,18.196c-.33069-.00317-.65833-.00519-1.00037-.01257-11.60742-.25128-19.31073-6.1239-27.44861-3.028A10.30386,10.30386,0,0,0,9.83844,25.1073a10.30392,10.30392,0,0,0,6.98029,9.95178c8.13788,3.09595,15.84119-2.77667,27.44861-3.028.31714-.00684.62012-.00842.92749-.01172A21.37493,21.37493,0,0,0,45.2677,18.196Z" /><path d="M13.43243,42.79919c-.17108-.04321-.32788-.10162-.49567-.14844a21.37364,21.37364,0,0,0,30.01337-6.04266C31.94232,39.739,26.06372,45.99066,13.43243,42.79919Z" /><path d="M43.11938,13.656A21.36985,21.36985,0,0,0,12.45325,7.69324c.32062-.09973.646-.1936.97919-.27783C26.129,4.2074,32.00092,10.54169,43.11938,13.656Z"/><path d="M24.99988,0A25,25,0,1,0,50,25.00012,25.02837,25.02837,0,0,0,24.99988,0Zm0,48.192A23.192,23.192,0,1,1,48.192,25.00012,23.2182,23.2182,0,0,1,24.99988,48.192Z" /></svg>Covers</a>
				</li>
			</ul>
		</div>
	</div>
	<div id="small-print" class="footer-block full-width">
		<div class="container">
			<br>
			<p>
							<a target="_blank" href="https://publicfiles.fcc.gov/tv-profile/kcpq">
					Online Public File				</a> &bull;
			
			
			
				<a href="https://q13fox.com/terms-of-service/">Terms of Service</a> &bull;
				<a href="http://privacy.tribunemedia.com/">Privacy Policy</a> <br class="visible-phone"> &bull;

				1813 Westlake Ave. N. Seattle, WA 98109
				<br class="visible-phone"> &bull;
				Copyright &copy; 2019, KCPQ
				<br class="visible-phone"> &bull;
				<a href="https://www.nexstar.tv/">Nexstar Broadcasting, Inc. | All Rights Reserved</a> &bull;
				Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=q13fox.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>			</p>
		</div>
	</div>
</footer>



<div id="email-alerts-modal" class="modal modal-small hide fade">
	<div class="modal-header">
		<button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
		<h3>Email Alerts</h3>
	</div>
	<div class="modal-body">
		<iframe class="iframe" id="subscribe_shortcode_iframe" width="100%" height="150" src="" frameborder="0" scrolling="no"></iframe>
	</div>
</div>

<!--[if IE]>
		<div class="ie-warning">
		<strong>Notice</strong>: you are using an outdated browser. <a href="https://techcommunity.microsoft.com/t5/Windows-IT-Pro-Blog/The-perils-of-using-Internet-Explorer-as-your-default-browser/ba-p/331732" target="_blank">Microsoft does not recommend using IE as your default browser</a>. Some features on this website, like video and images, might not work properly.  For the best experience, <a href="https://browsehappy.com/" target="_blank">please upgrade your browser</a>.	</div>
	<![endif]-->
<div class="ie-10-up hide">
		<div class="ie-warning">
		<strong>Notice</strong>: you are using an outdated browser. <a href="https://techcommunity.microsoft.com/t5/Windows-IT-Pro-Blog/The-perils-of-using-Internet-Explorer-as-your-default-browser/ba-p/331732" target="_blank">Microsoft does not recommend using IE as your default browser</a>. Some features on this website, like video and images, might not work properly.  For the best experience, <a href="https://browsehappy.com/" target="_blank">please upgrade your browser</a>.	</div>
	</div>

<!-- wpcom_wp_footer -->
<script>
window._taboola = window._taboola || [];
_taboola.push({ flush:true });
</script>

<script>
  var _comscore = _comscore || [];
  _comscore.push( { c1: "2", c2: "18314522" } );
  ( function() {
    var s = document.createElement( "script"), el = document.getElementsByTagName("script" )[0]; s.async = true;
    s.src = ( document.location.protocol == "https:" ? "https://sb" : "http://b" ) + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore( s, el );
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=18314522&cv=2.0&cj=1" />
</noscript>
			<script src="https://www.google.com/recaptcha/api.js?render=explicit&onload=bindCaptchaToModal" async defer></script>
		<script>
			function bindCaptchaToModal() {
				var $ = jQuery;

				jQuery('#report-a-typo-modal').on('show.bs.modal', function(e) {
					var $el = document.createElement('div');
					$($el).prop('id', 'captcha');
					$('.report-a-typo-form').append($el);
					try {
						grecaptcha.render( 'captcha', { sitekey: "6LevbhcTAAAAAIMHYEZSF0P1Ev0dBD4u4QiRZoLl" } );
					} catch( e ) {
					}

				});
			}

			document.addEventListener( 'DOMContentLoaded', function() {
				var $ = jQuery;

				$('.report-a-typo-form').validate({
						submitHandler: function(form) {
						form.submit();
					}
				});

				$('#report-a-typo-submit').on('click', function(e) {
					e.preventDefault();

					if ( $('.report-a-typo-form').valid() )
						$('.report-a-typo-form').submit();
				});
			})
		</script>
				<script type="text/javascript">
						var _sf_async_config={};
			_sf_async_config.uid = "15066";
			_sf_async_config.domain = "q13fox.com";
			_sf_async_config.useCanonical = "true";
				(function(){
			        function loadChartbeat() {
					window._sf_endpt=(new Date()).getTime();
					var e = document.createElement('script');
					e.setAttribute('language', 'javascript');
					e.setAttribute('type', 'text/javascript');
					e.setAttribute('src', "\/\/static.chartbeat.com\/js\/chartbeat.js" );
					document.body.appendChild(e);
				  }
				  var oldonload = window.onload;
				  window.onload = (typeof window.onload != 'function') ?
					 loadChartbeat : function() { try { oldonload(); } catch (e) { loadChartbeat(); throw e} loadChartbeat(); };
				})();
		</script>
<script type="text/template" id="infowindow-template">
<%
if ( featured_image_url !== '' ) {
%>
<a href="<%- permalink %>" target="_blank">
	<img src="<%-featured_image_url%>?w=<%-imagesize%>&h=<%-imagesize%>&crop=1" style="float:right; margin:14px 0 10px 10px; height:<%-imagesize%>px; width:<%-imagesize%>px;">
</a>
<% } %>

	<h5 style="margin-bottom:0;"><%=title%></h5>
	<em><%-date%></em>
	<p style="line-height:16px; font-weight:normal;"><%=excerpt%></p><a href="<%-permalink%>" class="text-small" target="_blank">Read more &rsaquo;</a>
</script>

  <div id='acm-tag-oop' class='prebid ad-wrapper' >
<script>
googletag.cmd.push(function() {
 googletag.display('acm-tag-oop');
});
</script>
  </div>
  		<script>
		var cb = function() {
			if ( pbjs.initAdserverSet ) {
				googletag.cmd.push( function() {
					if ( ACMBatches.secondBatchTags.length ) {
						googletag.pubads().refresh( ACMBatches.secondBatchTags, { changeCorrelator: false } );
					}
				});
				clearInterval(adRefInterval)
			}
		};
		var adRefInterval = setInterval( cb, 200 );
		</script>
		
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/q13fox.com\/2019\/12\/13\/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect\/":580656};
	</script>
							<div id="sharing_email" style="display: none;">
		<form action="/2019/12/13/there-must-be-something-wrong-with-him-stabbing-victim-detectives-hope-you-can-help-id-random-street-attack-suspect/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<div
				class="g-recaptcha"
				data-sitekey="6LcmyE0UAAAAALID28yVNg7pFCodGaArJzHitez_"
				data-theme="light"
				data-type="image"
				data-tabindex="0"></div>
			<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en" async></script>
			
			<img style="float: right; display: none" class="loading" src="https://s2.wp.com/wp-content/mu-plugins/post-flair/sharing/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/mu-plugins/likes/queuehandler.js,/wp-includes/js/underscore.min.js,/wp-includes/js/backbone.min.js?m=1572623339j'></script>
<script src='https://platform.twitter.com/widgets.js?ver=20111117'></script>
<script>
var TrbTv = {"subscribeUrl":"","sharingEnabled":"1","isArticle":"1","isMobile":"","lazyCtx":"","lazyCtxMultiplier":"0.8"};
</script>
<script>
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJytlO1WwyAMhm9IivvQ+cfjtaSQrXRAENJt9eqlO7N6zrQrO/5raZ436RsSeQxCkWf0LF0ngu12xifJR8OMUdQW1L42UYtgUHo8YESvjd9VbXqQJWz4neMGHSZ5MEFaUmD5IJayTbIm4sQRgnCkwZZjiqyFkLCcZCLLJtwBQj0X+vJKRwqajr6h7GwpvLV4cui7Us4i+GSNLs/YvncY++oAmQae7e1YMHjV13S6lxPcdK5OpfgR+kDGc6qc8XPhy8vc8AZtwDi7tG3nFRvyV8CPOVqKAWvPtAAPtmejpjJowpZGPMds4zlIiy5YgtxvsagW0pr6rHpp4lVTp026MwlobYYfBiscckP6VjPK8nQ+HyRFEas8i8Oe+U/1q48TyuOQwUcvhmjxWG0GkYvNKXsQb1T3p8Z4MHFtQGdxUUOUDlLew/lJDNsl5oFP32eFCnnBqf1w+d7c6+Jp9bJebtar5/YTQutUTw=='></script>
<script src='//player.ooyala.com/static/v4/production/core.min.js?ver=5.3.1'></script>
<script src='https://sb.scorecardresearch.com/c2/plugins/streamingtag_plugin_ooyalav4.js?ver=5.3.1'></script>
<script src='https://player.ooyala.com/static/v4/production/latest/analytics-plugin/Nielsen.min.js?ver=5.3.1'></script>
<script src='//player.ooyala.com/static/v4/production/video-plugin/main_html5.min.js?ver=5.3.1'></script>
<script src='//player.ooyala.com/static/v4/production/video-plugin/bit_wrapper.min.js?ver=5.3.1'></script>
<script src='//player.ooyala.com/static/v4/production/other-plugin/discovery_api.min.js?ver=5.3.1'></script>
<script src='//player.ooyala.com/static/v4/production/skin-plugin/html5-skin.min.js?ver=5.3.1'></script>
<script src='//player.ooyala.com/static/v4/production/ad-plugin/google_ima.min.js?ver=5.3.1'></script>
<script>
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/post-flair/sharing/sharing.js?m=1564557884h'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script><script>
  // Static Queue Snippet
!function(t,n){t[n]=t[n]||{nlsQ:function(e,o,c,r,s,i){return s=t.document,r=s.createElement("script"),r.async=1,r.src=("http:"===t.location.protocol?"http:":"https:")+"//cdn-gl.imrworldwide.com/conf/"+e+".js#name="+o+"&ns="+n,i=s.getElementsByTagName("script")[0],i.parentNode.insertBefore(r,i),t[n][o]=t[n][o]||{g:c||{},ggPM:function(e,c,r,s,i){(t[n][o].q=t[n][o].q||[]).push([e,c,r,s,i])}},t[n][o]}}}(window,"NOLBUNDLE");

  // SDK Initialization
  var nSdkInstance = NOLBUNDLE.nlsQ("PB1618036-3042-4EF9-9360-5E8AF7A7B903","nlsnInstance", {nol_sdkDebug: 0});

  // Content Metadata
  var nielsenMetadata = {
    type: 'static',
    assetid: 580656, // *DYNAMIC METADATA*: unique ID for each article **REQUIRED**
    section: "news", // *DYNAMIC METADATA*: section of site **REQUIRED**
    segA: '', // *DYNAMIC METADATA*: custom segment
    segB: '', // *DYNAMIC METADATA*: custom segment
    segC: ''  // *DYNAMIC METADATA*: custom segment
    };

  // Event 'staticstart' Call
  nSdkInstance.ggPM("staticstart", nielsenMetadata);
</script>
<script src="//stats.wp.com/w.js?60" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'41640066','blog_tz':'-8','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'41640066','v':'wpcom','tz':'-8','user_id':'0','post':'580656','subd':'tribkcpq'}]);
function st_vt() {var x=document.createElement("img");x.src="https://pixel.wp.com/g.gif?blog=41640066&v=wpcomvt&tz=-8&user_id=0&post=580656&subd=tribkcpq&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTdDSXAzMF1ST18/MkNCMnFKfkZOeTNscD18Nj1ULUFxTHBCNVdmTU0tcmErK3g4SVJDTWFIT0ktYmJVclt4Ti5MP1kvMS5yNVtiTH4uTmR8Ynl2X1g0eXRtbTVkRUdvOUI3NHBTQTgmejlpNlVpQVVhUSZzdVcrOEFbK2NnazJ4bHZ1R3lrMWhBfm4lSltpSXNjTT8rMTBSSTJ3JkJHMS9fdXMlWX44TA=='}]);
_stq.push([ 'clickTrackerInit', '41640066', '580656' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>
<!--
	generated 268 seconds ago
	generated in 0.206 seconds
	served from batcache in 0.002 seconds
	expires in 32 seconds
-->
